GX-9100 Software Configuration Tool

General Setup Instructions

• Introduction
• System Requirements
• Software Installation
• Connection to the DX Controller
• Connection to the DX LCD Display

Creating a Configuration

• Configuration Process Diagram
• Starting the GX-9100
• Defining Job Information
• Defining the Global Data and Password
• Defining Analog Inputs (AIs) and Digital Outputs (DOs)
• Defining Analog Outputs (AOs) and Digital Inputs (DIs)
• Defining Modules
• Defining Programmable Modules
• Defining Network Modules (DX Version 3.x Only)
• Defining PLC Modules
• Connecting and Disconnecting Modules
• Defining the Trend Log Module (for DX Versions 1.4, 2.4, 3.4, or Later)
• Reusing Configurations
• Saving the Configuration
• Downloading to a DX Controller
• Viewing Configurations

*Indicates those sections where changes have occurred since the last printing.
- Printing Configurations 89
- Creating Tag Name ASCII Files 93
- Creating DDL Files 97

Modifying Configurations 99
- Uploading a Configuration from the Controller *99
- Opening a Configuration File 101
- Modifying Inputs and Outputs 102
- Deleting Modules 103
- Modifying Modules *103
- Calibrating Analog Inputs and Outputs 105

Downloading and Uploading a DX Controller via an N30 Supervisory Controller *107
- Downloading *107
- Uploading *111

Configuring the DX LCD Display 115
- Configuration Process Diagram 115
- User Interface *116
- Defining the DX LCD Display Global Data 124
- Defining the Configuration Name 127
- Defining the Default Configuration 128
- Defining the Point Database *130
- Defining the TSn/OSn Module Descriptions *142
- Defining Trend Data *144
- Downloading a Configuration to the DX LCD Display *148
- Displaying the Configuration Codes 153
- Uploading a Configuration from the DX LCD Display Unit 154
- Printing a Configuration 156

Importing DOS GX-9100 Files 161

*Indicates those sections where changes have occurred since the last printing.
General Setup Instructions

Introduction

In this document, Building Automation System (BAS) is a generic term that refers to the Metasys® Network, Companion™, and Facilitator™ supervisory systems. The specific system names are used when referring to system-specific applications.

GX-9100 Graphic Configuration Software (GX Tool) configures the DX series of Extended Digital Plant Controllers, the XT-9100 and XTM-905 extension modules, and the DT-9100 DX Liquid Crystal Display (LCD). The GX Tool is part of the M-Tool suite of programming tools.

This manual assumes that the reader is familiar with the DX controllers, XT-9100, XTM-905, and DX LCD Display.

The DX controller processes the analog and digital input signals it receives, using 12 multi-purpose programmable function modules, a software implemented Programmable Logic Controller (PLC), time schedule modules, and optimal start/stop modules. It uses these components, as needed, to produce the required outputs, depending on the module configuration, operating parameters, and programmed logic.

The DX controller can accept eight analog inputs and eight digital inputs. It provides up to 14 output modules, which are configured to give 8 analog outputs (2 analog outputs in the Version 1 controller) and 6 digital outputs (triacs). The triacs can be configured separately to provide six On/Off or pulse outputs, six duration adjust outputs, 3-position adjust (incremental) outputs, three Start/Stop outputs, or any combination using up to six triacs.

The DX controller input/output can be extended by up to 64 remote inputs/outputs, analog or digital, depending on the type of the connected XT-9100 or XTM-905 extension module configurations.

Each XTM-905 with an XP module can provide either eight analog points or eight digital points. An XT/XTM can be expanded to provide eight additional digital points in one physical configuration by connecting two to four XP modules to the XT/XTM module.

The Version 3.x controller (LONWORKS® DX-912x or DX-9200) can receive and transmit analog and digital data over the LONWORKS network to other controllers. Each controller accommodates 16 network analog inputs, 16 network analog outputs, 8 blocks of 16 digital inputs, and 8 blocks of 16 digital outputs. Network inputs and outputs allow DX-912x controllers to share data with other DX-912x controllers on a LONWORKS N2E trunk without the need for a supervisory controller.
The DX-9200 series controllers have an interoperable network interface and may share data with other DX-9200 controllers and other LONMARK™ compliant devices on the LONWORKS network.

A configuration comprises a set of parameters for each module, which are stored in a series of memory locations in the controller. Through the GX Tool, each module is assigned a type, details are entered in its data window, and outputs (source points) are connected to the inputs (destination points) of other modules. The PLC requires the generation of a logic diagram using different types of logic instructions.

The DX LCD Display unit is configured to display up to 96 data points from the DX controller configuration. It also displays alarm data, time schedules, trend logs, and a user defined graphics screen. The GX-9100 is used to select data points for display and to define user text for all its various screens.

Finally, all the data is downloaded to the controller and the DX LCD Display unit. Information uploaded from the controller may also be displayed via the GX-9100 program.

Refer to Table 1 for additional information.

**Table 1: Related Information**

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Code Number</th>
<th>FAN</th>
</tr>
</thead>
<tbody>
<tr>
<td>DX LCD Display User’s Guide</td>
<td>LIT-6364120</td>
<td>636.4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1628.4</td>
</tr>
<tr>
<td>DX-9100 Extended Digital Controller Technical Bulletin</td>
<td>LIT-6364020</td>
<td>636.4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1628.4</td>
</tr>
<tr>
<td>DX-9100 Configuration Guide</td>
<td>LIT-6364030</td>
<td>636.4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1628.4</td>
</tr>
<tr>
<td>DX-9200 LONWORKS Compatible Digital Controller Technical Bulletin</td>
<td>LIT-1162250</td>
<td>1162</td>
</tr>
<tr>
<td>DX Commissioning Using the Point Template Program User’s Guide</td>
<td>LIT-6364080</td>
<td>636.4</td>
</tr>
<tr>
<td></td>
<td>LIT-1628480</td>
<td>1628.4</td>
</tr>
<tr>
<td>XT-9100 Technical Bulletin</td>
<td>LIT-6364040</td>
<td>636.4</td>
</tr>
<tr>
<td></td>
<td>LIT-1628440</td>
<td>1628.4</td>
</tr>
<tr>
<td>XT-9100 Configuration Guide</td>
<td>LIT-6364050</td>
<td>636.4</td>
</tr>
<tr>
<td></td>
<td>LIT-1628450</td>
<td>1628.4</td>
</tr>
<tr>
<td>LONWORKS Network Layout Technical Bulletin</td>
<td>LIT-1162150</td>
<td>1162</td>
</tr>
<tr>
<td>LONWORKS N2E Bus Technical Bulletin</td>
<td>LIT-6364100</td>
<td>636.4</td>
</tr>
<tr>
<td>M-Tool Overview and Installation Technical Bulletin</td>
<td>LIT-693100</td>
<td>693</td>
</tr>
</tbody>
</table>
System Requirements

Refer to the *M-Tool Overview and Installation Technical Bulletin (LIT-693100)* for details.

Software Installation

Refer to the *M-Tool Overview and Installation Technical Bulletin (LIT-693100)* for software installation details.

The installation procedure automatically creates or modifies an initialization file named GX9100.INI. It also sets up the program group, called *Configuration Tools*, and the icons needed for running the GX-9100 utilities, which are listed in the following table. An icon for the GX-9100 readme file is also created.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
<th>Documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>DX-9100</td>
<td>Configure the DX series controller and the XT/XTM-905 Extension Module and XT-9100 DX LCD Display.</td>
<td>GX-9100 Software Configuration Tool User's Guide (LIT-6364060)</td>
</tr>
<tr>
<td>DX Commissioning</td>
<td>Point Template program, to commission the DX series controller, obtain controller information, monitor points and control loops, override and adjust points.</td>
<td>DX Commissioning Using the Point Template Program User's Guide (LIT-6364080)</td>
</tr>
<tr>
<td>NDM Configuration</td>
<td>Create configuration files for the N2 Dialer Module (NDM) and related procedures.</td>
<td>NDM Configurator Application Note (LIT-6364090)</td>
</tr>
</tbody>
</table>

Switching Languages/ Defaults

The installed language file set determines the default temperature units, frequency, and language. To switch languages and program defaults without having to reinstall the GX-9100 program:

1. Copy the file GXRES.* to GXRES70.DLL
2. Copy the file DXMISC.* to DXMISC.LNG
3. Copy the file DXTEXT.* to DXTEXT.LNG

Note: The * indicates the file extension that is the first three letters of the language/defaults to which you are switching.

Enabling Password Protection for the DX Download/ Upload Dialogs (DX Version 1.4, 2.4, or 3.4)

To enable the download/upload password protection feature in the GX-9100, use a standard text editor, such as Windows® Notepad, to add the following entry in the [Settings] section of the GX9100.INI file (located in the Windows directory):

```
[Settings]
PasswordEnable=Yes
```

Note: You **must** use an upper case Y when entering Yes.
WARNING: Once the password feature is enabled, you cannot access the controller if the password is lost. Exercise extreme caution when using this feature.

If the entry is not present in the GX9100.INI file, the password protection feature is disabled by default, and the DX Password fields are not shown in the Download and Upload dialog boxes.

Note: If the [Settings] section is not present, add it also, using square brackets as shown above.

To change the controller version that is chosen by default in the GX-9100 program, use a standard text editor, such as Windows Notepad, to add or change the following entry in the [Settings] section of the GX9100.INI file (located in the Windows directory):

```
[Settings]
DefaultControllerVersion=<version number>.
```

Valid entries for the <version number> parameter are:

1.1, 1.2, 1.3, 1.4, 2.0, 2.1, 2.2, 2.4, 3.0, 3.1, 3.2, 3.3, and 3.4

If the <version number> variable is set to any value other than those listed above, or if the entry is not present in the GX9100.INI file, the GX Tool defaults to Version 2.4.

Note: If the [Settings] section is not present, add it also, using brackets as shown above.

A DT-9100 with firmware Version 3.00 or higher can be updated via Update Firmware under the DX LCD Display menu. This feature is only available when Yes has been entered in the [Firmware Download] section of the GX9100.INI file (located in the Windows directory), as follows:

```
[Firmware Download]
AllowFirmwareUpdate=Yes
```
When the GX Tool runs on a Personal Computer (PC) with M-Tool software, including the Loader User Interface program and the PC is connected to a network of N30 Supervisory Controllers, a DX controller on the N2 Bus of any N30 may be downloaded or uploaded over the network. The default setting in the GX9100.INI file (located in the Windows directory) enables download and upload via N30. A path to the load component user interface program, LoaderUI.exe, has been defined as follows:

[Settings]
N30Download=Yes
N30Executable=<path of the LoaderUI.exe program>

The default second line entry is:
N30Executable=C:\PROGRA~1\JOHNSO~1\SYSTEM~1\ LOADERUI.EXE

Note: The full path in M-Tool is:
C:\Program Files\Johnson Controls\System Tools\Loaderui.exe

If System Tools are installed in a non-default directory, specify the path of the LoaderUI.exe program.

If the N30Download entry is not present in the GX9100.INI file, or the entry is No, the Download via N30 and Upload via N30 menu items do not appear in the Action menu.

Note: If the [Settings] section is not present, add it, using square brackets as shown above.

A selected set of modules in a configuration can be saved into an application library and a selected set of logic blocks can be saved into a PLC library. The default path to the directories for these libraries is:

[Settings]
AppLibrary=<path of Application Library directory>
PLCLibrary=<path of PLC Library directory>

Recommended defaults:
AppLibrary=C:\WGX9100\AppLib
PLCLibrary=C:\WGX9100\PLCLib

Note: If the above data is not entered by the user, the default path to the library directory is the same as that to the <GX9100.EXE> directory, and the path for the first save action is written to the [Settings] section of the GX9100.INI file.
There are two methods of connecting the computer to the DX controller. For more information, refer to the Controller Access Technical Bulletin (LIT-6364013) in the Programming and Commissioning section of this manual (FANs 636.4 or 1628.4) or the DX-9200 LONWORKS Compatible Digital Controller Technical Bulletin (LIT-1162250).

Local access connection from the computer to the DX-9100, Version 1 or 2, is made via an IU-9100 or MM-CVTPRO converter unit that, in turn, must be connected to drive the N2 Bus (Bus 91) on which the DX-9100 controller resides. The controller must be disconnected from the supervisory system.

With this configuration, each DX-9100, with its connected XT-9100 and XTM-905 modules and any XT-9100 modules on the bus, can be downloaded one after the other, entering the appropriate controller address at the GX-9100 PC. The appropriate cables are supplied with the IU-9100 converter and CVTPRO units.

Notes: For owners of older MM-CVT101 converter units, please note that it is not compatible with the Windows NT® operating system. If you are using the Windows NT operating system, download directly via the RS-232 port, or upgrade to the CVTPRO. See connection details for download through the RS-232 port (Figure 1).

For connection details when using the CVTPRO, please refer to the Auxiliary Gear Technical Bulletin (LIT-6363080).

The DX-9100 Version 2 or DX-912x/DX-9200 Version 3 controller, with its connected XT-9100 and XTM-905 modules, may be downloaded directly via its RS-232 port. With this connection configuration, only one DX controller and its XT/XTMs can be downloaded.

Note: If you have a LONWORKS DX-912x/DX-9200 (Version 3.x), you cannot download via the LONWORKS trunk from the GX Tool. The only way to download for the DX-9200 is via the RS-232 port on the controller. The DX-912x may also be downloaded through a Metasys Operator Workstation (OWS).
### A) IU-9100 to PC Connection Details

<table>
<thead>
<tr>
<th>IU-9100</th>
<th>Plug 9-pin Female</th>
<th>PC</th>
<th>Plug 9-pin Male</th>
<th>IU-9100</th>
<th>Plug 25-pin Female</th>
<th>RS-232-C Port Plug 25-pin Male</th>
</tr>
</thead>
<tbody>
<tr>
<td>RS-232-C</td>
<td>9-pin Female</td>
<td>9-pin Male</td>
<td>9-pin Male</td>
<td>9-pin Male</td>
<td>9-pin Female</td>
<td>Male</td>
</tr>
<tr>
<td>GND 1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>TxD 3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>RxD 5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td></td>
</tr>
</tbody>
</table>

### B) DX Version 2 and 3 — Direct Download

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>RS-232-C</td>
<td>9-pin Male</td>
<td>9-pin Female</td>
<td>9-pin Male</td>
<td>9-pin Male</td>
<td>9-pin Female</td>
<td>Male</td>
</tr>
<tr>
<td>RxD 2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>TxD 3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>GND 5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td></td>
</tr>
</tbody>
</table>

### C) N2 Bus Download

Figure 1: Connection Details for Download
The serial cable provided with the DX LCD display unit is used for downloading the display configuration. Connect the 9-pin female plug labeled DX/PC to the COM1 or COM2 serial port of the PC (Figure 2). Plug the phone connector on the other end of the cable into the phone jack (labeled RS232 INPUT) on the DX LCD display.

Figure 2: Connecting the DX LCD Display to the PC Serial Port

Note: Before connecting the serial cable to the PC, switch on the DX LCD Display and wait for the Download/Upload screen to appear.
Creating a Configuration

The process for configuring a DX controller is shown in Figure 3.

Start the GX-9100 program.
Choose which version DX to configure.
Define job information.
Define Global Data.
Define XT, XTM, and EXP modules.
Define analog inputs and digital inputs.
Define analog outputs and digital outputs.
Define network inputs and outputs (Version 3 only).
Define programmable modules.
Define PLC diagrams.
Make connections.
Define trend log module.
Save the configuration.
Download the configuration.

Figure 3: DX Configuration Process
To start the GX-9100 software, from the Start menu, select Programs > Configuration Tools > GX-9100 or Programs > Johnson Controls > M-Tool > Configuration Tools > GX-9100. A GX9100 screen appears (Figure 4). Use the mouse or arrow keys to move around the screen.

**Figure 4: Main Screen for a DX Version 2.x or 3.x**

**Menu Bar**

The menu bar is across the top of the main screen. Click on these menu items with the left mouse button to display a list of options. The menu bar (Figure 5) groups the activities associated with configuration into eight categories.

**Figure 5: Menu Bar and Toolbar**
Available options display in black text. Options that cannot be chosen appear dimmed. To choose an option, click on it once. To leave the menu without choosing an option, click the left mouse button once anywhere on the screen outside of the menu. Refer to Table 3 for a detailed description of the items in each menu appears. Refer to Table 10 for a description of the toolbar buttons and functions.

**Table 3: File Menu Options**

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Opens a new configuration file.</td>
</tr>
<tr>
<td>Open</td>
<td>Opens an existing configuration file.</td>
</tr>
<tr>
<td>Import</td>
<td>Imports files generated by the DOS GX-9100, Version 2, configuration tool into the GX-9100 configuration tool.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the current configuration.</td>
</tr>
<tr>
<td>Save As</td>
<td>Saves a copy of the current configuration under a different name.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the current configuration.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Allows you to view the current configuration, as it will print on the page.</td>
</tr>
<tr>
<td>Print Setup</td>
<td>Allows you to set print parameters, including default printer, portrait or landscape, paper size and source, and page range.</td>
</tr>
<tr>
<td>Header/Footer</td>
<td>Allows you to set up user defined headers.</td>
</tr>
<tr>
<td>Read User Names</td>
<td>Reads the contents of an existing Tag name ASCII file into a GX-9100 configuration and modifies the configuration Tag names.</td>
</tr>
<tr>
<td>Write User Names</td>
<td>Creates a Tag name ASCII file from an existing GX-9100 configuration and saves it to disk.</td>
</tr>
<tr>
<td>Open from Library</td>
<td>Reads the selected file from the application library or PLC library onto the clipboard. Complete the insert action by selecting the destination location and executing the paste command.</td>
</tr>
<tr>
<td>Save to Library</td>
<td>Saves the selected set of modules in a configuration to the application library, or saves the selected logic blocks in a PLC page to the PLC library.</td>
</tr>
<tr>
<td>DDL File Options</td>
<td>Allows you to define the items to be written to the DDL files when the configuration is saved.</td>
</tr>
<tr>
<td>Exit</td>
<td>Terminates the GX-9100 configuration tool.</td>
</tr>
</tbody>
</table>
**Edit Menu**

Table 4 describes the Edit menu options.

**Table 4: Edit Menu Options**

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Cancels the last action of cut or paste.</td>
</tr>
<tr>
<td>Cut</td>
<td>Removes selected modules or logic blocks and copies them to the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies selected modules or logic blocks to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the set of modules or logic blocks from the clipboard that were last cut, copied, or inserted from the library.</td>
</tr>
<tr>
<td>Add PM</td>
<td>Brings up a submenu to add one of several types of programmable modules to the configuration.</td>
</tr>
<tr>
<td>Configure</td>
<td>Brings up a submenu that allows you to configure the highlighted module.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected module. For hardware I/O modules, only the configuration is deleted and the module remains on the screen.</td>
</tr>
<tr>
<td>Data</td>
<td>Brings up a data screen with information about the selected module that can be viewed and edited.</td>
</tr>
<tr>
<td>Change Module Number</td>
<td>Allows you to change the number of the highlighted module.</td>
</tr>
<tr>
<td>Global Data</td>
<td>Allows you to edit information that affects the whole configuration, including temperature units, frequency, initialization on power up, counter type, daylight saving start and end date, password, and user configuration code.</td>
</tr>
<tr>
<td>Add Alarm Disable</td>
<td>Adds an alarm disable function block to the configuration.</td>
</tr>
<tr>
<td>Connect</td>
<td>Connects source and destination points.</td>
</tr>
<tr>
<td>Disconnect</td>
<td>Disconnects previously made connections.</td>
</tr>
<tr>
<td>Calibration</td>
<td>Allows you to calibrate analog input and outputs, and trim the accuracy of the realtime clock.</td>
</tr>
<tr>
<td>Job Information</td>
<td>Allows you to enter information pertaining to the configuration, such as job name, controller name, engineer, and branch.</td>
</tr>
</tbody>
</table>
**View Menu**

The View menu contains various options that allow you to alter the way the configuration looks on the screen.

Table 5 describes the various View menu options.

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Selected</td>
<td>Changes the view to only show the modules that are currently selected and the connections between these modules. (To select more than one module at a time, press Ctrl while clicking on each.)</td>
</tr>
<tr>
<td>Show All</td>
<td>Returns the view to show every module in the configuration.</td>
</tr>
<tr>
<td>Show User Names</td>
<td>Displays the user defined names for all modules that have them.</td>
</tr>
<tr>
<td>Show Tag Names</td>
<td>Displays the predefined Tag Names for all modules.</td>
</tr>
<tr>
<td>Show Connections</td>
<td>Shows all connections for the currently selected module.</td>
</tr>
<tr>
<td>Trace</td>
<td>Creates a graphical trace of all modules connected to a selected module for easy tracing of a path, without showing lines to and from other modules.</td>
</tr>
<tr>
<td>Snap to Grid</td>
<td>Allows snapping boxes to a grid, permitting easier alignment.</td>
</tr>
</tbody>
</table>

**Action Menu**

The Action menu allows you to upload and download configurations to and from the DX controller. Table 6 describes the various Action menu options.

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload</td>
<td>Uploads a configuration from a DX controller.</td>
</tr>
<tr>
<td>Download</td>
<td>Downloads a configuration to a DX controller.</td>
</tr>
<tr>
<td>Upload via N30</td>
<td>Uploads a configuration from a DX controller to the PC via an N30 controller. Only appears if enabled in the GX9100.INI file. (See the Software Installation section for details).</td>
</tr>
<tr>
<td>Download via N30</td>
<td>Downloads a configuration to a DX controller from the PC via an N30 controller. Only appears if enabled in the GX9100.INI file. (See the Software Installation section for details).</td>
</tr>
</tbody>
</table>
**Controller Menu**

The Controller menu allows you to choose the controller for which you are creating a configuration. Table 7 describes the various Controller menu options.

**Table 7: Controller Menu Options**

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Each option on</td>
<td>The initial screen to create a configuration for the indicated controller</td>
</tr>
<tr>
<td>the Controller</td>
<td>versions as follows:</td>
</tr>
<tr>
<td>menu sets up</td>
<td>DX Version 1.1, 1.2, 1.3: Versions 1.1, 1.2, and 1.3 of the DX-9100 controller</td>
</tr>
<tr>
<td>the initial</td>
<td>DX Version 1.4: Version 1.4 of the DX-9100 controller (supports Trend)</td>
</tr>
<tr>
<td>screen to create</td>
<td>DX Version 2.0, 2.1, 2.2: Versions 2.0, 2.1, and 2.2 of the DX-9100 controller</td>
</tr>
<tr>
<td>a configuration</td>
<td>DX Version 2.3, 2.4: Version 2.4 of the DX-9100 controller (supports Trend)</td>
</tr>
<tr>
<td>for the</td>
<td>DX Version 3.0, 3.1, 3.2: Versions 3.0, 3.1, and 3.2 of the DX-912x LONWORKS</td>
</tr>
<tr>
<td>indicated</td>
<td>compatible controller</td>
</tr>
<tr>
<td>controller</td>
<td>DX Version 3.3, 3.4: Version 3.4 of the DX-912x and DX-9200 LONWORKS</td>
</tr>
<tr>
<td>versions</td>
<td>compatible controllers (supports Trend)</td>
</tr>
<tr>
<td>as follows:</td>
<td></td>
</tr>
</tbody>
</table>

**Window Menu**

The Window menu allows you to cascade, tile, or arrange multiple configuration windows on the screen. Table 8 describes the various Window menu options.

**Table 8: Window Menu Options**

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Arranges multiple configurations on the screen in overlapping stair-stepped</td>
</tr>
<tr>
<td></td>
<td>panes.</td>
</tr>
<tr>
<td>Tile</td>
<td>Arranges multiple configurations into equally sized panes that fill</td>
</tr>
<tr>
<td></td>
<td>the screen but do not overlap.</td>
</tr>
<tr>
<td>Arrange</td>
<td>Arranges icons and windows on the screen.</td>
</tr>
</tbody>
</table>

**DX LCD Display Menu**

See *DX LCD Display Menu* under *User Interface* in the *Configuring the DX LCD Display* section in this manual.
Help Menu

The Help menu allows you to view the copyright screen. Table 9 describes the Help menu options.

Table 9: Help Menu Options

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX9100 Help Topic</td>
<td>Launches Help window with an index of GX-related topics.</td>
</tr>
<tr>
<td>Help Using</td>
<td>Launches a window containing help topics for Microsoft® Windows Help.</td>
</tr>
<tr>
<td>About</td>
<td>Displays copyright and version information for the GX-9100 Tool.</td>
</tr>
</tbody>
</table>

Launch the GX Tool Help window (Figure 6) by selecting GX-9100 Help Topics from the Help menu, by pressing F1, or Shift + F1. The help window closes automatically when you close the GX Tool.
The toolbar is located just below the menu bar. It contains buttons that perform specific functions when clicked on. Table 10 shows the toolbar buttons and describes their functions.

**Table 10: Toolbar Buttons**

<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Menu Bar Equivalent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; New</td>
<td></td>
<td>Opens a new configuration file.</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td></td>
<td>Opens an existing configuration file.</td>
</tr>
<tr>
<td>File &gt; Save</td>
<td></td>
<td>Saves the current configuration.</td>
</tr>
<tr>
<td>Edit &gt; Add PM</td>
<td></td>
<td>Brings up a submenu to add one of several types of programmable modules to the configuration.</td>
</tr>
<tr>
<td>File &gt; Print</td>
<td></td>
<td>Brings up the series of print dialog boxes, which allows you to print select items and set print parameters.</td>
</tr>
<tr>
<td>Edit &gt; Cut</td>
<td></td>
<td>Removes selected modules or logic blocks and copies them to the clipboard.</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td></td>
<td>Copies selected modules or logic blocks to the clipboard.</td>
</tr>
<tr>
<td>Edit &gt; Paste</td>
<td></td>
<td>Pastes the set of modules or logic blocks from the clipboard that were last cut, copied, or inserted from the library.</td>
</tr>
<tr>
<td>Edit &gt; Undo</td>
<td></td>
<td>Cancels the last action of cut or paste.</td>
</tr>
<tr>
<td>File &gt; Open from Library</td>
<td></td>
<td>Reads the selected file from the application library or PLC library onto the clipboard. Select the destination location and execute the paste command to complete the insert action.</td>
</tr>
<tr>
<td>File &gt; Save to Library</td>
<td></td>
<td>Saves the selected set of modules in a configuration to an application library, or saves the selected logic blocks in a PLC page to the PLC library.</td>
</tr>
</tbody>
</table>
Pop-Up Menus

Pop-up menus display when you right-click on a point or module. The pop-up menu that displays depends on which type of point or module you click. A pop-up menu (Figure 7) appears when you click on an unconfigured Digital Output.

![Pop-up Menu Example](image)

**Figure 7: Unconfigured Digital Output Pop-Up Menu Example**

A pop-up menu (Figure 8) appears when you click on a configured module.

![Pop-up Menu Example](image)

**Figure 8: Configured Module Pop-Up Menu Example**
**User Names**

Each I/O point, connection source point, destination point, and programmable module has a predetermined Tag Name. *(See Appendix A: Source Points and Appendix B: Destination Points for details on these names.)* However, you can define an 8-character user name that identifies the function of each point and programmable module in the application being configured.

For programmable modules, inputs, and outputs, define these names in the data window’s User Name field. Note that you can also add a 24-character description in the data window’s Description field.

For connection points, define the names by clicking the Input-Tag button (for destination points) or the Output-Tag button (for source points) in the appropriate data window, enter the names in the fields next to the points. The View menu gives you the option to display the configuration with the predefined Tag Names or the user names.

**Choosing which DX Version to Configure**

The DX initial screen automatically defaults to Version 2.4 when started. If you are using a different version controller, change the screen to reflect that version.

To switch between the versions:

1. Click Controller on the menu bar. The current controller version is the checked menu item.
2. Select another controller version from the menu. The screen changes to that version.
**Defining Job Information**

To define job information, select Job Information from the Edit menu. The Job Information dialog box (Figure 9) appears.

**Figure 9: Job Information Dialog Box**

**Defining the Global Data and Password**

To define the global data and password:

1. Select Global Data from the Edit menu. The Edit Global Data dialog box (Figure 10) appears.

**Figure 10: Edit Global Data Dialog Box**
2. Fill in the empty data fields.

Notes: Enter the User Configuration Code as a number between 0 and 9999. This code identifies the configuration being edited and is downloaded to the controller and displayed on the front panel of the DX controller at startup (Version 1.1 or later). (The GX Tool accepts numbers up to 65535, but only numbers up to 9999 display correctly on the DX front panel.) The User Configuration Code is also used by the DX LCD Display unit to identify the configuration, so it displays the correct screens.

The Password protects a configuration loaded into a controller. Once the password is downloaded into the controller along with the configuration, the controller only allows another download or upload when the same password is entered. Enter a password of 0000 to disable the password function.

The Password field appears dimmed and cannot be edited if the Password feature has not been enabled in the GX9100.INI file (see Enabling Password Protection for the DX Download/Upload Dialogs (DX Version 1.4, 2.4, or 3.4) under Software Installation at the beginning of this guide).

3. Click OK to save the values and close the dialog box.

Defining analog inputs and digital outputs is a two step process. First, configure the AI or DO using the pop-up menus. Second, define the data associated with the AI or DO using the data windows.

To configure an analog input or digital output:

1. Right-click the AI or DO you want to configure and a pop-up menu (Figure 11) appears.

2. Left-click the AI or DO type from the pop-up menu. A double border appears around the point to indicate that it is configured.
To define the data associated with the AI or DO:

1. Right-click the configured AI or DO, and select Data from the pop-up menu that appears, or highlight the point, and select Data from the Edit menu. A Data window (Figure 12 or Figure 13) appears.

2. Enter values into the empty data fields. Use an asterisk (*) to make or modify connections from the data window.

3. Click the Input-Tag button to assign user names to the destination points (if applicable).

4. Click the Output-Tag button to assign user names to the source points (if applicable).

5. Click OK to save the values and exit the data window.

**Figure 12: Active Analog Input Data Window**
To define analog outputs and digital inputs, only enter the data associated with the AO or DI.

To enter the associated data:

1. Right-click the configured AO or DI and select Data from the pop-up menu that appears, or highlight the point and select Data from the Edit menu. A Data window (Figure 14 or Figure 15) appears.

---

**Figure 13: P.A.T. Digital Output Data Window**
Enter values into the empty data fields. Use an asterisk (*) to make or modify connections from the data window.

3. Click the Input-Tag button to assign user names to the destination points (if applicable).

4. Click the Output-Tag button to assign user names to the source points (if applicable).

5. Click OK to save the values and exit the data window.
Table 11 shows the maximum number of modules by type you can use in a configuration.

**Table 11: Module Type Limits**

<table>
<thead>
<tr>
<th>Type of Module</th>
<th>Maximum Number Allowed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control</td>
<td>12 total</td>
</tr>
<tr>
<td>Numeric</td>
<td></td>
</tr>
<tr>
<td>Totalization</td>
<td></td>
</tr>
<tr>
<td>Sequencer</td>
<td></td>
</tr>
<tr>
<td>Binary Sequencer</td>
<td></td>
</tr>
<tr>
<td>XT or XTM</td>
<td>8 total</td>
</tr>
<tr>
<td>Time Schedule</td>
<td>8</td>
</tr>
<tr>
<td>PLC</td>
<td>8</td>
</tr>
<tr>
<td>Optimum Start/Stop</td>
<td>2</td>
</tr>
<tr>
<td>Analog Constants</td>
<td>1</td>
</tr>
<tr>
<td>Digital Constants</td>
<td>1</td>
</tr>
<tr>
<td>Exception Days</td>
<td>1</td>
</tr>
<tr>
<td>LRS1-32</td>
<td>1</td>
</tr>
<tr>
<td>LRS33-64</td>
<td>1</td>
</tr>
<tr>
<td>Trend Log</td>
<td>1</td>
</tr>
<tr>
<td>Network Modules</td>
<td></td>
</tr>
<tr>
<td>NDO</td>
<td>8</td>
</tr>
<tr>
<td>NDI</td>
<td>8</td>
</tr>
<tr>
<td>NAO</td>
<td>16</td>
</tr>
<tr>
<td>NAI</td>
<td>16</td>
</tr>
</tbody>
</table>

Note: Once you reach a module’s limit, that module type is removed from the Add PM menu. Also, module types not supported by the selected controller version do not appear on the Add PM menu.
To configure XT and XTM modules:

1. Click the Add PM button on the toolbar, or select Add PM from the Edit menu.
2. Select XT or XTM from the Add PM menu. A submenu (Figure 16 and Figure 17) appears with options for the XP type. XPs and XTM can be analog, digital, or expanded digital.

Notes: Some XT, XTM, and XP modules described in this document are unique to local markets and may not be available on a global basis.

The XP expanded digital options (preceded with EXP) only appear if the preceding module is an XT or XTM and not defined as EXP.

The inputs/outputs of an XP are connected to the first XT or XTM module. An expanded digital XT or XTM (EXP) represents the inputs/outputs of the second XP on the preceding XT or XTM.

The first XT/XTM software module represents two hardware modules.

![Diagram of configuration menus]

Figure 16: XT Extension Module Configuration Menus
Configuring Analog XT Modules

For an XT module, there is only one type of analog XP module: six analog inputs and two analog outputs (6AI 2AO).

The analog XP module choices for an XTM module are described in Table 12.

**Table 12: XTM Analog Modules**

<table>
<thead>
<tr>
<th>Module</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>4AI*</td>
<td>Four analog inputs</td>
</tr>
<tr>
<td>4AO*</td>
<td>Four analog outputs</td>
</tr>
<tr>
<td>4AI 4AO*</td>
<td>Four analog inputs and four analog outputs (2 XP modules)</td>
</tr>
<tr>
<td>8AI*</td>
<td>Four analog outputs (2 XP modules)</td>
</tr>
<tr>
<td>8AO*</td>
<td>Four analog outputs (2 XP modules)</td>
</tr>
<tr>
<td>6AI 2AO</td>
<td>Six analog inputs and two analog outputs</td>
</tr>
</tbody>
</table>

* Not available in North America.
To configure an analog input for an XT or XTM:

1. Select XT or XTM from the Add PM menu.

2. Left-click to select the desired analog configuration from the XT or XTM submenu (Figure 16 and Figure 17). Additional analog inputs and outputs appear around the sides of the GX9100 screen (Figure 18).

3. Left-click to place the XT or XTM module block on the screen.

4. Right-click the desired XTnAIm and a pop-up menu (Figure 19) appears.

Figure 18: XT Analog Inputs and Outputs

Note: Input and output tags for XTM modules are the same as for XT modules (e.g., XTnAIm, XTnAOm).
5. Left-click Active or Passive to configure the analog input. A double border in the AI’s function block indicates that it is configured.

**XT AI and AO Data Definition**

To define the data associated with XT or XTM analog inputs and outputs:

1. Right-click the configured XT AI or XT AO and select Data from the pop-up menu that appears, or highlight the point and select Data from the Edit menu. A Data window (Figure 20 or Figure 21) appears.

![Figure 20: XT/XTM Analog Input Data Window](image)
2. Enter the desired values into the empty data fields. Use an asterisk (*) to make or modify connections from the data window.

3. Click the Input-Tag button to assign user names to the destination points (if applicable).

4. Click the Output-Tag button to assign user names to the source points (if applicable).

5. Click OK to save the values and exit the data window.

**Figure 21: XT/XTM Analog Input Data Window**

XT modules (Figure 22), digital or expanded digital XP modules, have a maximum of eight digital inputs (8DI or EXP8DI), four digital inputs and four digital outputs (4DI 4DO or EXP 4DI 4DO), or eight digital outputs (8DO or EXP 8DO).
XTM modules (Figure 23), digital or expanded digital XP modules of the type XPM-4x1 (momentary output relays), XPL-4x1 (magnetically latched output relays), or XPE-4x1 (electrically latched output relays) can also be configured.

![Configuration Menu for XTM](Fig33)

**Figure 23: Digital and Expanded Digital Extension Module Configuration Menu for XTM**

Note: Modules of type XPE-4x4 (x=0, 1, 2, or 3) must be configured as 4DI 4DO and XPE-4x4, x=4, 5, 6, or 7, as 8DO.

To configure digital or expanded digital extension modules:

1. Select XT or XTM from the Add PM menu.
2. Select the desired combination of digital inputs and/or outputs from the XT/XTM submenu by left-clicking. Additional inputs and/or outputs appear around the sides of the GX9100 screen (Figure 24).

Note: Expanded digital module options (options preceded with EXP) appear on the submenu only if the preceding module is the same module type (XT or XTM), and the XP type is not defined as EXP.
Figure 24: XT Digital Inputs and Outputs

Note: Input and output tags for XTM modules are the same as for XT modules (e.g., XTnDIm, XTnDOm).

3. Left-click to place the XT or XTM module block on the screen. Right-click for outputs and a pop-up menu (Figure 25) appears.

Figure 25: XT/XTM Digital Output Configuration Menu

4. Left-click On/Off or Pulse to configure the digital output. A double border appears in the DO’s function block to indicate that it is configured.
Note: Configure all DOs as On/Off or Pulse regardless of whether they are used. The only exceptions are the 4-output relay modules (XP-9107 and XPE-4x4, x=4, 5, 6, or 7). When only one 4-output module is installed, select 8DO, but only configure DO1-DO4. When two 4-output modules are installed, configure both as one 8DO module, and configure DO1-DO8.

IMPORTANT: Configure XPM-4x1, XPL-4x1, and XPE-4x1 modules as On/Off. The action of the outputs is determined by the hardware, not by the configuration.

**XT DI and DO Data Definition**

To define the data associated with XT and XTM digital inputs and outputs:

1. Right-click the configured XT DI or XT DO and select Data from the pop-up menu that appears, or highlight the point, and select Data from the Edit menu and a Data window (Figure 26 or Figure 27) appears.

   **Figure 26: XT/XTM Digital Input Data Window**

   **Figure 27: XT/XTM Digital Output Data Window**
2. Enter the desired values in the empty data fields. Use an asterisk (*) to make or modify connections from the data window.

3. Click the Input-Tag button to assign user names to the destination points (if applicable).

4. Click the Output-Tag button to assign user names to the source points (if applicable).

5. Click OK to save the values and exit the data window.

**XT and XTM Data Definition**

To define the data associated with the operation of the complete XT or XTM module set (including EXP modules):

1. Right-click the XT or XTM box and select Data from the pop-up menu that appears, or highlight the module, then select Data from the Edit menu. A Data window (Figure 28 or Figure 29) appears.

![Figure 28: XT Data Window](image1)

![Figure 29: XTM Data Window](image2)
2. Enter the desired values into the empty data fields.
3. Click the Output-Tag button to assign user names to the source points.
4. Click OK to save the values and exit the data window.

To configure a programmable module:

1. Click the Add PM button on the toolbar, or select Add PM from the Edit menu. The Add PM menu (Figure 30) appears.

![Figure 30: Programmable Module Configuration Menu](image)
2. Select the type of module from the menu. If opting for a control or numeric module, a submenu (Figure 31) appears.

![Figure 31: Control and Numeric Configuration Menus](image)

Once you have selected the type, a highlighted box with a dashed border and the type name and module number appears next to the pointer.

3. Move the module to the desired location and left-click. You can move the module at any time by clicking and dragging it to a new position on the screen.

To define the data associated with a programmable module:

1. Right-click on the programmable module and select Data from the pop-up menu that appears, or highlight the module and select Data from the Edit menu. The PID Module Data window (Figure 32) appears.
Figure 32: PID Module Data Window

2. Enter values into the empty data fields. Use an asterisk (*) to make or modify connections from the data window.

3. Click the Input-Tag button to assign user names to the destination points (if applicable).

4. Click the Output-Tag button to assign user names to the source point (if applicable).

5. Click the Data-2 button to access the second page if the module has two pages and a second PID Data page (Figure 33) appears.

Figure 33: PID Module Second Page

6. Enter the desired values in the empty data fields of the second window. Use an asterisk (*) to make or modify connections.
7. Click OK to save the new values and return to the first window, or Cancel to return to the first window without saving the values.

8. Click OK to save all values and exit the data window.

The network variables transmit data between DX-912x controllers on the same LONWORKS N2E network. The LONWORKS N2E network supports DX-9120 or DX-9121 controllers (not both on one network), and the GX Tool provides all data to the controllers for the LONWORKS network configuration. No third-party tool is required.

The network variables transmit data between DX-9200 controllers on an open LONWORKS network. They also transmit data from any other LONMARK compliant devices on the network to the DX. Refer to the DX-9200 LONWORKS Compatible Digital Controller Technical Bulletin (LIT-1162250) for details on the use of each network variable before defining network modules. When configuring a DX-9200 controller, network module destinations are not defined in the GX Tool. Network connections between network variables in different controllers (source and destination) must be defined by a third-party LONWORKS network configuration tool.

To configure a network module:

1. Click the Add PM button on the toolbar, or select Add PM from the Edit menu.

2. Select Network Modules from the menu and the network modules submenu (Figure 34) appears.

3. Select Network Analog Input, and a highlighted box with a dashed border and the name NAIn appears next to the pointer.

Figure 34: Network Modules Submenu
4. Move the module to the desired position on the page and left-click. Move the module at any time by clicking and dragging it to a new position on the screen (Figure 35).

5. Repeat the procedure using the submenu options Network Digital Input (NDIn), Network Analog Output, and Network Digital Output (NDOn) to define the network modules.

![Figure 35: Network Analog and Digital Modules](image-url)
To define the data associated with the network analog input module:

1. Right-click on the configured NAIn, and select Data from the pop-up menu that appears, or highlight the module and select Data from the Edit menu. The Network Analog Input [NAI1] - Data window (Figure 36) appears.

   ![Network Analog Input Data Window](analogin)

   **Figure 36: Network Analog Input Data Window**

2. Enter the user name and description as appropriate.

3. Click the Output-Tag button, and assign user names to the source points as appropriate.

4. Click OK to save all entries and exit the data window.

To define the data associated with the network digital input module:

1. Right-click on the configured NDIn, and select Data from the pop-up menu that appears, or highlight the module, then select Data from the Edit menu and the network digital input data window (Figure 37) appears.

   ![Network Digital Input Data Window](digitin)

   **Figure 37: Network Digital Input Data Window**
2. Enter the user name and description as appropriate.
   An Output-Tag can be assigned to each of the 16 binary points that each NDIn accommodates.

3. Click Output-Tag to enter the user names into the network digital input Output-Tag data window (Figure 38).

![Figure 38: Network Digital Input (NDInOutput-Tag Window)](image)

4. Click OK to save all entries and exit the data window.
To define the data associated with the network analog output module:

1. Right-click the configured NAOn and select Data from the pop-up menu that appears, or highlight the module and select Data from the Edit menu and the network analog data window (Figure 39) appears.

2. Enter the user name and description.

3. Enter the Input-Tag for the source point of the network analog output.
   
   Note: The network analog output is connected to one source point in the same DX controller. Use an asterisk (*) to make the connections in the data window.

### Figure 39: Network Analog Output (NAOn) Data Window

NAOn Destination Definitions (DX-912x Only)

To define NAOn destinations:

1. Enter the destination controller’s addresses and the corresponding network analog input points. Click Data-2 to define Destination Controllers 8-16.

2. Click OK to save all entries and exit the data window.
The NDOn contains up to 16 source binary points.

To define network digital outputs:

1. Right-click the configured NDOn and select Data from the pop-up menu that appears, or highlight the module and select Data from the Edit menu. The network digital output data window (Figure 40) appears.

2. Enter the user name and description. The connected source points are shown.

3. Enter Input-Tag for the source points.

Note: The NDO contains up to 16 source binary points in the same DX controller. Use an asterisk (*) to make connections between DX source points and NDOn in the data window.
**NDOn Destination Definitions (DX-912x Only)**

To define NDOn destinations:

1. Click Data-2 and the network digital output dialog box (Figure 41) appears.

![Network Digital Output (NDOn) Data-2 Window](image)

<table>
<thead>
<tr>
<th>Destination #</th>
<th>Ctrlr.Addr</th>
<th>NDI#</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#3</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#4</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#6</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#7</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#8</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#9</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#10</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#11</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#12</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#13</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#14</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#15</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>#16</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**Figure 41: Network Digital Output (NDOn) Data-2 Window**

2. Enter the destination controller’s addresses and the corresponding network digital input points.

3. Click OK to save all entries and exit the data window.

---

**Defining PLC Modules**

The GX-9100’s software-implemented Programmable Logic Controller (PLC) supports most of the functions available in dedicated PLCs. PLC functions are defined in ladder diagrams. In the GX-9100 Graphic Configuration software, the PLC is subdivided into eight pages: PLC1 to PLC8. A separate ladder diagram and a separate module block on the screen represent each PLC.
Table 13 lists common instructions for building a ladder diagram.

**Table 13: PLC Instructions**

<table>
<thead>
<tr>
<th>Module</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOP</td>
<td>No operation</td>
</tr>
<tr>
<td>LOAD</td>
<td>Loads the value of the addressed logic variable into the result status.</td>
</tr>
<tr>
<td>LOAD NOT</td>
<td>Loads the inverted value of the addressed logic variable into the result status.</td>
</tr>
<tr>
<td>AND</td>
<td>Logical AND between the value of the addressed logic variable and the result status.</td>
</tr>
<tr>
<td>AND NOT</td>
<td>Logical AND between the inverted value of the addressed logic variable and the result status.</td>
</tr>
<tr>
<td>OR</td>
<td>Logical OR between the value of the addressed logic variable and the result status.</td>
</tr>
<tr>
<td>OR NOT</td>
<td>Logical OR between the inverted value of the addressed logic variable and the result status.</td>
</tr>
<tr>
<td>ANDB</td>
<td>Logical AND operation between two blocks</td>
</tr>
<tr>
<td>ORB</td>
<td>Logical OR operation between two blocks</td>
</tr>
<tr>
<td>OUT</td>
<td>Transfers the result status to the addressed logic variable.</td>
</tr>
<tr>
<td>OUT NOT</td>
<td>Transfers the inverted result status to the addressed logic variable.</td>
</tr>
<tr>
<td>COS</td>
<td>Change-of-state of the result status set the result status to 1 for one program cycle.</td>
</tr>
<tr>
<td>SET</td>
<td>Sets the addressed logic variable to the logical 1 if the result status is 1.</td>
</tr>
<tr>
<td>RST (RESET)</td>
<td>Resets the addressed logic variable to the logical 0 if the result status is 1.</td>
</tr>
<tr>
<td>RSR (RESTART)</td>
<td>Marks the place in the graphic ladder diagram for the restart of the program cycle when there has been no power failure or processor reset. (Location of RSR is given in END instruction in program code.)</td>
</tr>
</tbody>
</table>

**Add the PLC Module Block**

To add the PLC module block:

1. Click the Add PM button on the toolbar, or select Add PM from the Edit menu.
2. Select PLC from the Add PM menu.
3. Place the PLC module block on the screen by dragging it to the appropriate position, and click once to anchor it.
4. Double-click on the PLC module block and the GX9100 - [Untitled PLC] screen (Figure 42) appears.
Figure 42: Initial Ladder Diagram

Notes: The top of the diagram is numbered (PLC1-PLC8). The User Name and Description fields can only be changed from the PLC block’s data window.

The diagram has eight rows. Each row has eight dots called hot points. Double-clicking on the control box in the corner allows you to leave the diagram. Upon leaving the diagram, you are prompted to save changes if you have not done so.

PLC Menu Bar

The menu bar on the PLC screen contains five options. Left-click to choose an option.

File Menu - PLC

The File menu contains options to open, save, close, and print PLC ladder diagrams. Refer to Table 14.
Table 14: File Menu Options - PLC

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Saves the current PLC page ladder diagram.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the current PLC page.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the current PLC page.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Displays the current PLC page ladder diagram as it will appear printed.</td>
</tr>
<tr>
<td>Print Setup</td>
<td>Sets print parameters, including default printer, portrait or landscape,</td>
</tr>
<tr>
<td></td>
<td>paper size and source, and page range.</td>
</tr>
<tr>
<td>Header/Footer</td>
<td>Defines user-defined headers and footers.</td>
</tr>
<tr>
<td>Open from Library</td>
<td>Reads the selected file from the PLC library onto the clipboard.</td>
</tr>
<tr>
<td></td>
<td>The insert action is completed by selecting the destination location and</td>
</tr>
<tr>
<td></td>
<td>executing the paste command.</td>
</tr>
<tr>
<td>Save to Library</td>
<td>Saves the selected logic blocks in a PLC page to the PLC library.</td>
</tr>
</tbody>
</table>

**Edit Menu - PLC**

The Edit menu contains options to create and change the ladder diagram. Refer to Table 15.

Table 15: Edit Menu Options - PLC

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Cancels the last action of cut or paste.</td>
</tr>
<tr>
<td>Cut</td>
<td>Removes logic blocks and places them on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies logic blocks to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes logic blocks from the clipboard.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all logic blocks on the page.</td>
</tr>
<tr>
<td>Insert Line</td>
<td>Inserts a blank line in the ladder diagram at the first hot spot of an</td>
</tr>
<tr>
<td></td>
<td>existing logic block.</td>
</tr>
<tr>
<td>Page Reformat</td>
<td>Moves all blank lines to the bottom of the page.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected logic blocks.</td>
</tr>
<tr>
<td>Clear</td>
<td>Deletes the whole page. (To restore, close without saving and reopen PLC</td>
</tr>
<tr>
<td></td>
<td>module.)</td>
</tr>
</tbody>
</table>

**View Menu - PLC**

The View menu allows the selection of User Names or Tag Names. Refer to Table 5.

**Window Menu - PLC**

The Window Menu allows you to cascade, tile, or arrange multiple configuration windows on the screen. Refer to Table 8.
**Help Menu - PLC**

The Help menu calls up a separate window containing an index of GX Tool-related help topics. Refer to Table 9.

**Toolbar - PLC**

The toolbar is located just below the menu bar. It is identical to the toolbar in the main screen. Refer to Table 10.

**Add Instructions to the Ladder Diagram**

To add instructions to the ladder diagram:

1. Click on the hot point at the top left and the PLC List Box (Figure 43) appears.

![Figure 43: PLC Instruction List Box](image)

2. Select LOAD or LOAD NOT as the first instruction. If you select LOAD and click OK, the LOAD symbol appears (Figure 44).
Figure 44: Adding the LOAD Symbol

Note: The LOAD NOT symbol looks like the LOAD symbol with a slash through the L.

The first element of subsequent rows or rows on subsequent pages may also be the RSR (Restart) instruction. The RSR instruction marks the beginning of PLC program execution.

All rows and pages before the RSR instruction are executed only when the DX controller is powered up after a power failure. This feature allows the creation of a power up routine starting in Row 1 of Page 1 and ending in the row before the RSR instruction.

You can define only one RSR instruction. If no RSR instruction is defined, the PLC program begins at Row 1 on Page 1.

Note: It is not possible to select a hot point if it is preceded by a blank column or if the row above the point is empty.

3. Continue to click on unused hot points and add instructions to the ladder diagram (Figure 45) until your PLC program is complete.
Figure 45: Example of a PLC Ladder Diagram

Creating Logic Blocks

To create a logic block within a line, select LOAD or LOAD NOT to begin the block and ENDB to end the block. The letter B marks the end of the block.

To create OR loops within logic blocks, select ORB and then LOAD or LOAD NOT. The OR block will begin at the LOAD or LOAD NOT instruction of the currently open logic block and end at the point where the ORB was entered. The block will automatically be completed with NOP instructions, which may subsequently be changed to AND instruction (Figure 46). The elements in the second row form OR blocks.
Figure 46: Example of a Logic Block within a Line
To assign an associated logic variable to each instruction:

1. Click on the center of the first PLC instruction. The intermediate PLC List menu (Figure 47) showing all configured modules appears.

![PLC List Box]

Figure 47: Intermediate Menu for Associated Variables

2. Select a module from the intermediate menu and click OK. For example, if you selected DX/XT I/O from the PLC List Box menu shown (Figure 47), the PLC List dialog box for DX/XT I/O (Figure 48) appears.
3. Select one of the logic variables and click OK. If you selected DI1, the ladder diagram now contains the DI1 variable (Figure 49).

![Figure 48: All Logic Variables Under DX/XT I/O](image)

![Figure 49: LOAD Symbol with Associated Variable DI1](image)
4. Continue to add associated variables to all remaining logic instructions (Figure 50).

Deleting a PLC Instruction

To delete a PLC instruction, select Edit > Delete.

When a LOAD or LOAD NOT instruction is deleted, all subsequent instructions in the logic block are also deleted. Rebuild or complete the logic block by adding the appropriate instructions. Use the Edit > Page Reformat menu to fill blank lines created when deleting a LOAD or LOAD NOT.

Note: Delete is only allowed for LOAD, LOAD NOT, AND, and AND NOT instructions.

Editing Logic Blocks

**Cut, Copy and Paste**

Cut and Copy to paste logic blocks to new locations in the same PLC page or to a different PLC page. Logic blocks begin with a LOAD or LOAD NOT instruction on the left side and end with an OUT, OUT NOT, SET, or RST instruction on the right side. Select the block by pressing Ctrl and left-clicking on any hot spot in the logic block. Alternatively, use the arrow keys to place the cursor on a hot spot, and press Ctrl and either Enter or the Spacebar.

You can select more than one block at one time. Selected blocks are highlighted in red in the ladder diagram (shown in gray in Figure 51).
To cancel the selection of a logic block, repeat the selection procedure for that block. To cancel all selections, press Esc or left-click anywhere on the screen (not on a hot spot). Any other action on the PLC page also cancels any logic block selection.

To cut a selected logic block, select Edit > Cut, click the cut symbol in the toolbar, or press Ctrl + X.

To copy a selected logic block, select Edit > Copy, click the copy symbol in the toolbar, or press Ctrl + C.

Right-click on any hot spot in the selected logic block to access the Edit menu.

To paste the contents of the clipboard, place the cursor on a hot spot on the left side of the screen. Right-click to call up the Edit menu and click Paste, or press Ctrl + V. An error message appears if an insufficient number of free lines exist in the PLC page to complete the paste action. If you insert a block within a page, the blocks below the new block move down.

To paste and replace one or more successive logic blocks in the ladder diagram with blocks on the clipboard, select logic blocks to replace and complete the paste action as described above. In this case a warning box appears to confirm replacement (and deletion) of the selected blocks.
Notes: The paste command will always paste the last logic block stored on the clipboard.

When pasting a logic block into a new or different configuration, only those item references that exist in the target configuration will be pasted. The complete logic structure is always pasted, but references to items that do not exist in the configuration will be deleted.

**Insert Line**

Right-click on a hot spot and select Insert Line from the PLC edit menu that appears (Figure 52). Repeat to insert multiple lines.

![Figure 52: PLC Edit Menu](image)

**Page Reformat**

Select Edit > Page Reformat (or press Ctrl + R) to remove a free line from the ladder diagram and place it at the bottom of the page.
To save selected module Select File > Save to Library menu, or press Ctrl + B. The Save to PLC Library dialog box (Figure 53) appears.

![Save to PLC Library Dialog Box](image)

**Figure 53: Save to PLC Library Dialog Box**

The default path to the library directory is read from the GX9100.INI file. Change the path, if desired, and enter the file name with the .PXS extension. Click OK to save the logic block.

To open a logic block from the PLC library:

1. Select File > Open from Library from the menu, or press Ctrl + L. The Open from PLC Library dialog (Figure 54) appears.

2. Select a file with the extension .PXS and click OK.

![Open from PLC Library Dialog Box](image)

**Figure 54: Open from PLC Library Dialog Box**
### Saving and Exiting the PLC Diagram

To save and exit the PLC diagram:

1. Click the Save button on the toolbar, or select Save from the File menu to save the current session in the DX configuration.

2. Double-click the control box in the upper left corner of the window (or at the left of the menu bar if the window is maximized), or click on the close box in the upper right corner of the window (or at the right of the menu bar if the window is maximized) to leave the PLC ladder diagram and return to the main configuration window.

Note: When exiting a PLC diagram, blank lines are automatically moved to the bottom of the page. When opening a PLC diagram, no blank lines exist between logic blocks.

### Connecting and Disconnecting Modules

This section describes how to make and remove logical connections between the source and destination points of the various modules.

Make connections in the following ways:

1. Drag from one connection point to another (Figure 55).

2. Use the Connect option.

3. Enter the source point within a data window.
**Using the Click-Drag Option**

Double-click on both modules to maximize them.

Place the bent arrow cursor on the source point.

Click and hold the left mouse button, and drag the bent arrow to the destination point.

Release the left mouse button.

Click Yes or No to choose whether you want an inverted connection (digital inputs only).

The connection appears as a line between the two modules.

Figure 55: Using the Click-Drag Method to Make Connections
Using the Connect Option

To use the Connect option:

1. Left-click the module that contains the source point.
2. Right-click outside of the highlighted module. The pop-up module menu appears.
3. Select Connect from the module menu.
   Or
   Select Connect from the Edit menu.
   or
   Press F5.

The module connect dialog box (Figure 56) appears containing source points for the selected module.

4. Choose a source point, and then click OK.
5. Left-click the destination module.
6. Right-click outside the module. The pop-up module menu appears.
7. Select Connect from the module menu.
   or
   Select Connect from the Edit menu.
   or
   Press F5.

The module connect dialog box (Figure 57) appears containing destination points for the selected module.
8. Choose a destination point, and then click OK. If applicable, a dialog box (Figure 58) appears asking if the connection is inverted. Click Yes or No.

9. A line appears showing the connection between the two modules (Figure 59).
Figure 59: Example--Connected Modules

Note: Once a destination point has been used, it does not appear in the destination point dialog box and new source points are unable to connect to it. The only way to connect a new source point is to delete the old connection and define a new one.

Making Connections within a Data Window

To make a connection within a data window:
1. Left-click on the module that contains the destination point.
2. Right-click outside of the highlighted module. The pop-up module menu appears.
3. Select Data from the module menu.
   or
   Select Data from the Edit menu.
   The module data window (Figure 60) appears.
4. Select the data field (box) in the Module Data window that corresponds to the desired connection. The blinking cursor appears in the box.

Note: Only descriptions followed by an arrow (\(\rightarrow\)) accept connection information.

5. Type an asterisk (*) in the box. A menu listing the valid configuration modules for the selected field (Figure 61) appears.

6. Select one of the valid configuration modules by double-clicking on it or by highlighting it and clicking OK.

A menu of all valid PID module outputs appears (Figure 62).
Figure 62: Valid Outputs Window

7. Double-click to select one of the outputs listed or highlight it and click OK.

   Notes: If a logic output is selected, a dialog box appears and asks if you want an inverted connection. Answer appropriately. You are returned to the data window.

   The name appears in the edit box. A line appears showing the connection between the two modules after exiting the data window.
To remove a block’s current connection, either use the scissors cursor (Figure 63) to cut the connection line at the destination block, choose the Disconnect option, or delete the connection in the data window.

**Using the Scissors Cursor**

Place the cursor at the point where it turns into the Scissors cursor.

Click the left mouse button.

Click Yes to confirm that you want to delete the connection.

The connection is removed.

**Figure 63: Removing the Connection Using the Scissors Cursor**
Using the Disconnect Option

To disconnect the modules using the Disconnect option:

1. Click on the destination module with the left mouse button.
2. Right-click outside the module. The pop-up module menu appears.
3. Select Disconnect from the module menu.
   or
   Select Disconnect from the Edit menu.
   or
   Press F4.

The Disconnect dialog box (Figure 64) appears showing all destination points of the selected module that are currently connected.

4. Choose the destination point you wish to disconnect, then click OK. A dialog box (Figure 65) appears to confirm connection deletion.

5. Click Yes to delete. The connection line is removed from the screen.
Using the Data Window

To disconnect the modules using the data window:

1. Left-click on the module that contains the connection.
2. Right-click outside of the highlighted module. The pop-up module menu appears.
3. Select Data from the module menu.
   or
   Select Data from the Edit menu.
   The Module Data window appears.
4. Select (highlight) the entire name in the data field (box) that you want to delete, then press the Delete key.
   or
   Select the data field (box) with the connection you want to delete, then press the asterisk (*) key.
   A menu appears listing the valid configuration modules for the selected field. Click the Delete button.
   You are returned to the data window. Press Enter or click the OK button.

Showing Connections

There are three ways to show the module connections in detail:

1. Double-click connected modules to reveal all source and destination points of that module. Lines appear between all connected source and destination points.
2. Use the data option of the module menu, a data window appears which contains all destination points and parameters of the module.
3. Select Show Connections from the View menu to bring up the Connections dialog box (Figure 66) showing all source point connections for the selected module.
The Trend Log module provides 12 trend log channels, each records data from either 1 analog item or from a set of 8 logic variables (logic variable byte). The trend is used to provide data for Metasys Point History in DX controllers that are connected remotely (i.e., via dial-up) to the Metasys system or for a local DX LCD Display.

When the DX controller is connected to a Metasys system by an NDM dialer and telephone lines, the trend data is read whenever a connection is made by the Metasys system. The data is stored in the point history file of AI, Analog Output Setpoint (AOS), and Binary Input (BI) objects when they are mapped to the items being recorded. When the Metasys Point History option is selected for a trend log channel, only those items that can be mapped to Metasys objects are allowed, and the trend parameters are set by the GX-9100 Tool to default values for the Point History feature in the Metasys system.

You must link the Historical Trend Read Request (HTRR) logic variable to the DIAL request logic variable in a PLC module to initiate a dial-up connection when a trend record buffer is full. Since a DX Version 3.x cannot be connected to a Metasys system by the NDM dialer and telephone lines, trend logs cannot be configured for Metasys Point History in these versions.

Trend channels that are not used for Metasys Point History are freely configurable. For analog items, the sampling rate can be entered, and the stored values may be either the average, maximum, or minimum values during the period or the instantaneous value at the time of reading. Logic variables are recorded with a time and date stamp when there is a change of value. All channels may be displayed on the DX LCD Display.
To add the Trend Log module to the configuration:

1. Click the Add PM button on the toolbar, or select Add PM from the Edit menu.
2. Select Trend from the Add PM menu.
3. Place the Trend Log module block on the screen by dragging it to the appropriate position, and then click once to anchor it. Move the module at any time by clicking and dragging it to a new position on the screen.

To define the Trend Log module channels:

1. Double-click on the Trend Log module block. The Trend Log data window (Figure 67) appears.

![Figure 67: Trend Log Data Window](image)

Note: The Trend Log data table has 12 rows, each defines a channel.
2. Right-click the channel to configure, and select Data from the pop-up menu that appears, or highlight the channel, then select Data from the Edit menu. The Data dialog box (Figure 68) for the Trend Log channel appears.

![Data Dialog Box for Trend Log Channel](image1)

**Figure 68: Data Dialog Box for Trend Log Channel**

Note: Metasys Point History appears dimmed and cannot be selected for a Version 3.x DX controller, because it cannot be monitored remotely with an NDM dialer.

3. Check the Metasys Point History box if required, then enter the desired Tag Name of the item to be recorded. Use an asterisk (*) for the Tag Name to select the item from a list of valid Tag Names. Click OK to continue to the next dialog box, which depends on what you entered for the Tag Name, as follows:

   - If you entered a specific Tag Name (e.g., AI1), the next dialog box is the appropriate Trend Data dialog box for the selected item. Skip to Step 7 in this procedure, which describes the Trend Data dialog boxes.
   - If you entered an asterisk (*), then a series of dialog boxes appear that allow you to select from item categories and subcategories until you find the individual item that you want to add. Continue with the next step (Step 4) in this procedure.

Notes: If you entered an asterisk (*) in the Tag Name field of the Data dialog box (Figure 68), the Select dialog box (Figure 69) showing item categories appears.

![Select Item Category Dialog Box](image2)

**Figure 69: Select Item Category Dialog Box**
The categories and items shown in the series of dialog boxes depend on the controller version and whether you selected Metasys Point History.

4. Double-click to select a category, or highlight it and then click OK. Another dialog box appears listing subcategories of the category you chose in the previous dialog box. For example, if you chose DX Input/Output, the Select dialog box (Figure 70) appears.

![Figure 70: Select Subcategory Dialog Box](Fig75)

5. Double-click to select a subcategory, or highlight it and then click OK. Another dialog box appears listing either additional subcategories or individual items. For example, if you chose Analog Input 1-8, a Select dialog box (Figure 71) appears and lists individual points.

![Figure 71: Select Item Dialog Box](Fig76)

Note: There may be several dialog boxes listing subcategories before you reach the dialog box listing individual items (similar to Figure 71). Repeat Step 6 until you find the item you want to add to the table. Refer to Appendix C: Trend Log Items for a list of the Tag Names available in a Trend Log module.
6. Select the item you want to add to the table by double-clicking on it or by clicking on it to highlight it and then clicking OK. One of two Trend Data dialog boxes appears, depending on whether you selected an analog item (Figure 73) or logic variable set (Figure 74).

Notes: Save additional memory points by using this procedure:

When selecting a logic variable, choose the byte that contains the required variable. All variables in the set are then available for Metasys Point History or for the DX LCD Display. Since a logic variable set is recorded when any one of its variables changes state, we recommend assigning LRS logic variable bytes to the trend log and connecting the source variables (the ones that you wish to trend) to the LRS variables in a PLC module.

For example, if you want to trend TS1OUT, DO1, DO2, BI1, BI2, LRS18, LRS19, and LRS20, the following PLC logic would set LRS1–LRS8 with the values you want to trend (Figure 72).

![Example](image)

**Figure 72: Trend Example**

![Trend Data](image)

**Figure 73: Trend Data Dialog Box for an Analog Item**
7. Enter the desired values in the data fields, or select from the drop-down list boxes. Table 16 describes the fields, their possible values, and their default values.

Table 16: Trend Data Entries and Options

<table>
<thead>
<tr>
<th>Dialog Field</th>
<th>Possible Values</th>
<th>Default (= Metasys Point History Setting)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sampling Rate</strong> (period of time between records)</td>
<td>5, 10, 15, 20, 60 Sec**</td>
<td>Analog Input: 30</td>
</tr>
<tr>
<td></td>
<td>1 to 1440 Min</td>
<td>Analog Output: 30</td>
</tr>
<tr>
<td><strong>Units for Sampling Rate</strong></td>
<td>Sec (seconds)</td>
<td>Min</td>
</tr>
<tr>
<td></td>
<td>Min (minutes)</td>
<td></td>
</tr>
<tr>
<td><strong>Read Request</strong> (number of new samples to set HTRR)</td>
<td>Analog: 0 to 61</td>
<td>Analog Input: 48</td>
</tr>
<tr>
<td></td>
<td>Logic Variables: 0 to 30</td>
<td>Analog Output: 48</td>
</tr>
<tr>
<td><strong>Sampling Mode</strong> (analog value to record at end of each period)</td>
<td>Actual</td>
<td>Analog Input: 48</td>
</tr>
<tr>
<td></td>
<td>Average</td>
<td>Analog Output: 48</td>
</tr>
<tr>
<td></td>
<td>Maximum</td>
<td>Logic Variables: 10</td>
</tr>
<tr>
<td></td>
<td>Minimum</td>
<td></td>
</tr>
<tr>
<td><strong>Synchronization</strong> (exact time of the start of trend recording)</td>
<td>None</td>
<td>Hour</td>
</tr>
<tr>
<td></td>
<td>Day (midnight 00:00:00)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hour (xx:00:00)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Minute (xx:xx:00)</td>
<td></td>
</tr>
</tbody>
</table>

* Logic Variable bytes are read each second but only recorded when there has been a change-of-state in at least one bit.
** When seconds are selected, the GX Tool automatically increases the entered value to one of the specified values and gives an error if the value is over 60.
*** A Read Request value of 0 disables the Read Request feature for the Item or Logic Variable.

Note: If Metasys Point History was checked, the GX-9100 Tool sets the trend parameters to appropriate default values, and these values cannot be changed.

8. Click OK to save the channel data and return to the Trend Log definition table.
To save the Trend Log definitions and exit the Trend Log Data window:

1. Click the Save button in the toolbar, or select Save from the File menu to save the current session in the DX configuration.

2. Double-click on the control box in the upper left corner of the window (or at the left of the menu bar if the window is maximized), or click on the close box in the upper right corner of the window (or at the right of the menu bar if the window is maximized) to close the Trend Log Data window and return to the main configuration window.

In any free line of a PLC module, add a LOAD element assigned to the logic variable HTRR (listed under DIAGNOSTIC), followed by a SET element assigned to the logic variable DIAL (listed under SUPERV). If other logic variables have already been configured to set the DIAL variable, add the HTRR variable as an OR element to the ladder diagram (Figure 75).

**Figure 75: Ladder Logic to Set DIAL from Trend Log**

For more information on this application, refer to the DX-9100 Configuration Guide (LIT-6364030) or the NDM Configurator Application Note (LIT-6364090) in FAN 636.4.
A set of modules in a configuration can be reused in the same configuration or transferred to a new configuration. PLC modules are not included in this feature. Refer to Defining PLC Modules - Editing Logic Blocks for information on the reuse and transfer of PLC modules.

I/O Modules

When I/O Modules are part of the set of modules to reuse or transfer, sufficient modules of the same type must be available in the target configuration. If XT or XTM I/O modules are included, create the appropriate number of XT or XTM modules in the target configuration before reusing or transferring modules.

For DX I/O modules, a sufficient number of unused modules must be available. You can overwrite existing modules.

Analog Constants, Digital Constants, Logic Result Status

Transfer ACO, DCO, and LRS modules only if they do not exist in the target configuration. Redefining connections to these modules is part of the transfer procedure. Enter values for ACO and DCO items once the transfer process is complete.

To select more than one module, hold Ctrl and click the desired modules.

Notes: All connections between the selected modules are transferred to the target configuration.

Connections to modules not included in the selected set must be deleted or changed during the paste process to fit the target configuration to complete the transfer. See Modifying Programmable Modules.

The data content of I/O modules included in the selected set replaces the data content of I/O modules in the target configuration. If the module is an output module with an existing connection, the module cannot be overwritten until the connection is first deleted.

To reuse I/O modules that exist in the target configuration and preserve the existing data in the modules, do not Select them.
Each programmable and time schedule module number changes to the number of the next available unused module in the target configuration during the transfer process, and can be changed by the user. The references to connections between modules in the selected set are changed automatically and cannot be modified during the transfer process.

**Cutting Modules**
Select the modules to be cut and pasted, select the Edit-Cut menu, or press Ctrl + X. The selected modules are removed from the configuration and copied to the clipboard.

**Copying Modules**
Selected modules to copy, select the Edit > Copy menu, or press Ctrl + C. The selected modules are copied to the clipboard.

**Pasting Modules**
To paste the set of modules on the clipboard into the currently open configuration, select the Edit-Paste menu, or press Ctrl + V. The following sequence of dialog boxes are displayed according to the type and quantity of modules to be pasted:

If there are too many modules for the target configuration the GX9100 warning box (Figure 76) appears.

![Figure 76: Insufficient Modules Available Warning Box](image)

**Figure 76: Insufficient Modules Available Warning Box**

If there are DX I/O modules that do not exist in the target configuration (typically AO9 - AO14), a warning box appears. Cancel the paste action and change the target configuration to the appropriate controller version (typically Version 2.x or 3.x).

If the required number of XT or XTM modules do not already exist in the target configuration, the GX9100 warning box (Figure 77) appears.

![Figure 77: XT/XTM I/O Modules Not Available Warning Box](image)
Add the appropriate number of XT or XTM modules to the target configuration and restart the paste action.

**Modifying I/O Modules**

If modules copied to the clipboard include physical I/O modules, the Modify I/O Modules dialog box (Figure 78) appears. Use this box to modify the module I/Os before you paste the modules into the configuration.

![Modify I/O Modules Dialog Box](image)

**Figure 78: Modify I/O Modules Dialog Box**
You can change any I/O reference in the New column by clicking on the item reference and then pressing Shift + *, or by double-clicking on the item. A list of available I/O module references of the same type appears and you can choose a new reference. When the changes are made, select from the options in Table 17.

**Modifying Programmable Modules**

If the modules copied to the clipboard include programmable modules, the Modify Programmable Modules dialog box (Figure 79) appears. Use this box to modify connections before pasting modules into the configuration.

![Modify Programmable Modules Dialog Box](image)

The next available module number is inserted and can be changed by the user.

All connections with a defined source are shown. A source within the selected set of modules will be marked with an *, and cannot be changed. You can delete or change source references not in the selected set of modules by clicking on the item reference and then pressing Shift + *, or by double-clicking on the item. A list of available references of the appropriate type appears and you can choose a new source reference. When the changes are made, select from the options in Table 17.
Table 17: Programmable Module Paste Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous</td>
<td>Displays Modify Programmable Modules dialog box (Figure 79).</td>
</tr>
<tr>
<td>Next</td>
<td>Displays next dialog box. A warning box appears if any of the new references do not exist in the target configuration.</td>
</tr>
<tr>
<td>Paste All</td>
<td>Pastes the selected modules without displaying individual dialog boxes. A warning box appears if any of the selected modules cannot be pasted.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Aborts the paste process. The selected set of modules remains available on the clipboard for a subsequent paste action, until you place another set on the clipboard by a Cut or Copy command.</td>
</tr>
</tbody>
</table>

Modifying Time Schedule Modules/Optimal Start Modules/Network Input and Output Modules

If modules copied to the clipboard include Time Schedule Modules, Optimal Start Modules, or Network Input and Output Modules, a Modify Programmable Modules dialog box containing connection and source options appears. Follow the procedure for Modifying Programmable Modules to modify the module numbers and source references.

Modifying Output Module Connections

If modules copied to the clipboard include output modules, a dialog box allows you to change the source references for connections. You cannot change the module number in this dialog box. Refer to the Modifying I/O Modules section for details about changing output module numbers (references). When the changes are made, select an option from Table 18.

Table 18: Modifying Output Module Connection Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous</td>
<td>Displays previous dialog box.</td>
</tr>
<tr>
<td>Next</td>
<td>Displays next dialog box. (Not available in the last dialog box.)</td>
</tr>
<tr>
<td>Paste All</td>
<td>Pastes the selected modules. The paste action cannot change a connection to an output module that already exists in the target configuration. A warning box appears (Figure 80) showing all connections that cannot be overwritten. You must change the output module number to an unused output module; cancel the paste action and delete the existing connection in the target configuration; or remove the output module from the selected set of modules.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Aborts the paste process. The selected set of modules remains available on the clipboard for a subsequent paste action, until another set is placed on the clipboard by a Cut or Copy command.</td>
</tr>
</tbody>
</table>
To save a selected set of modules to the application library, select File > Save to Library, or press Ctrl + B. The Save to Application Library dialog box (Figure 81) appears.
The default path to the library directory is read from the GX9100.INI file. Change the path if desired and enter the file name with the .LXS extension. Click OK to save the set of modules as an application.

To retrieve a set of modules from the application library, select File > Open from Library, or press Ctrl + L. Select a file with the extension .LXS from the Open from Application Library dialog box (Figure 82) that appears and click OK.

![Open from Application Library Dialog Box](image)

**Figure 82: Open from Application Library Dialog Box**

To save a GX-9100 configuration, click the Save button on the toolbar or select Save from the File menu. The configuration saves under the current file name.

**Note:** If you save a configuration while in Show Selected mode, the entire configuration saves. The next time you open the saved file, select Show All from the View menu to see the entire configuration.

If you are saving the configuration for the first time, the File Save As dialog box (Figure 83) appears.
To save a GX-9100 configuration under a different file name, select Save As from the File menu. Type in the new file name, and click OK. The configuration will be saved under the new name.

To download the configuration to the DX controller:

1. Select Download from the Action menu. The Download dialog box (Figure 84) appears.

Note: The DX Password field appears only if Password Protection has been enabled in the GX9100.INI file.
2. Select the item to download and the proper clicking on the radio buttons.  
   
   Note: If downloading from the OWS, the item selected must be DX, XT/XTM, and Network or DX and XT/XTM. The port selected must be File. This creates a file with a .DXF extension. Move the file from the GX-9100 directory to the Metasys directory under the System 91 subdirectory. This is the default directory. Then it can be downloaded from a DX Device Object Focus window in the OWS. **A DX-9200 controller cannot be downloaded from the OWS.**

3. Enter the address of the controller in the Address data field to download the configuration. The address must be a number between 1 and 255. The address must be correct, even if saved to a file, since the OWS checks that the program address matches the DX address. If you selected XT/XTM as the item to be downloaded, no address is required (it is already stored in the configuration), and the Address field appears dimmed and cannot be selected.

   Notes: If connected to the DX, the XT/XTM cannot be downloaded individually from the OWS.

   Address 255 is reserved for the DX LCD Display with N2 Bus operation. Select another address if there is a DX LCD Display on the N2 Bus of the controller selected. If 255 is entered, the GX9100 dialog box (Figure 85) appears.

![Figure 85: Address Warning Dialog Box](image)

4. Enter the number in the DX Password field if the DX controller already has a configuration with a password (only for DX Version 1.4, 2.4, 3.4, or later). The download fails if the password number is incorrect.

   Note: If the global data password in the configuration being downloaded is different from the password in the controller, the password is changed in the controller. Also, the DX Password field only appears if the password protection feature is enabled in the GX9100.INI file (see *Enabling Password Protection for the DX Download/Upload Dialogs [DX Version 1.4, 2.4, or 3.4]* under *Software Installation* at the beginning of this guide).
5. Click OK. The hourglass appears on the screen until the configuration has downloaded.

**Viewing Configurations**

**Show Selected**

To view only certain points and modules in a configuration:

1. Select the points and modules to view by clicking on them while holding down the Ctrl key. (This allows you to select more than one point or module at a time.)

2. Select Show Selected from the View menu.

3. Select Show All from the View menu to see all points and modules on the screen.

**Trace**

The Trace feature makes all lines (connections) invisible except those connected to a selected module. This allows you to easily trace a path when other connections are present (Figure 86).
Follow these steps to trace the connections for the BIN-SEQ3 module:

1. Select the module that you wish to trace by clicking on it.

2. Select Trace from the View menu. All connections become invisible except for the connections of the selected module (Figure 87). The connections for that module remain visible for easy tracing.

3. Click on another module to trace the connections path for that module. To trace multiple modules at the same time, use Ctrl-click on each subsequent module.

4. Select Trace again from the View menu to turn off the Trace function.

**Show User Names**

If you have defined user names for the configuration, you may want to view those names rather than the predefined point and module tags. To do this, select Show User Names from the View menu. To return to viewing point and module tags, select Show Tag Names from the View menu.
To set up headers and footers for printing configurations:

1. Select Header/Footer from the File menu. The Header/Footer Dialog window (Figure 77) appears.

![Figure 88: Header/Footer Dialog Box](image)

2. Complete the Company Name edit box.

3. Select the desired field positions for the header and footer using the drop-down lists. The information for Job Name, Controller Name, Branch, Engineer, and Created on is entered in the Job Information screen. Refer to *Defining Job Information* in this document.

Notes: An example of the header and footer styles is shown below.

Note that a new configuration has default settings. The default Company Name is Johnson Controls. The default position for each header/footer field is shown in the example below.

The header includes descriptors, like **JOB NAME:**, but the footer does not (Figure 89).
4. Select whether the header should appear on every page or only the first page by selecting the appropriate radio button (Figure 88).

5. Select OK if you are satisfied with the format or Cancel to revert to the default settings.

To view how the configuration will look when printed:

1. Select Print Preview from the File menu. The Print Items dialog box (Figure 90) appears.
2. Select the options to preview by clicking on the radio buttons and check boxes. Table 19 describes some of the options in this dialog box.

Table 19: Print Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selection (You may select only one of the following.)</strong></td>
<td></td>
</tr>
<tr>
<td>All Items</td>
<td>Prints items listed in the Items box, including module data, job information, calibration information, and global data.</td>
</tr>
<tr>
<td>Graphic Selection</td>
<td>Prints all items selected in the configuration layout.</td>
</tr>
<tr>
<td>Items (Listed below)</td>
<td>Prints all items with checked boxes in the Items box.</td>
</tr>
<tr>
<td><strong>Print Format (You may select only one of the following.)</strong></td>
<td></td>
</tr>
<tr>
<td>Draft</td>
<td>Prints the configuration as it would be printed in Draft mode (without page headers and footers).</td>
</tr>
<tr>
<td>Final</td>
<td>Prints the configuration as it would be printed in Final mode (with page headers and footers).</td>
</tr>
<tr>
<td><strong>Data Selection (You may select more than one of the following.)</strong></td>
<td></td>
</tr>
<tr>
<td>Data</td>
<td>Includes data for every module with the configuration printout.</td>
</tr>
<tr>
<td>Input Tags</td>
<td>Includes a list of defined input-tags for every module with the configuration printout.</td>
</tr>
<tr>
<td>Output Tags</td>
<td>Includes a list of defined output-tags for every module with the configuration printout.</td>
</tr>
</tbody>
</table>

3. Click OK. A print preview screen (Figure 91) appears.

Note: The page on the screen looks exactly like the printed document. Zoom in to view half- and quarter-page views by clicking the Zoom In button. Click the Zoom Out button until you return to the full page view. To view two pages at a time, click the Two Page button. To return to the one page view, click One Page. To view pages not displayed on the screen, click Next Page or Prev Page, or use the scroll bar.
4. Click Close if you do not want to print the configuration at this time. To print the document, click Print. The Print dialog box (Figure 92) appears. Continue with Step 3 in the Print Sequence section.

**Print Sequence**

To print a configuration:

1. Click the Print button on the toolbar, or select File > Print. The Print Items dialog box (Figure 90) appears.

2. Select print options (refer to Table 19), and click OK. The Print dialog box (Figure 92) appears.
3. Choose the print range by clicking on one of the radio buttons.  
   Note: If you choose Page, you also need to enter the starting and  
   ending page numbers in the From: and To: data fields.

4. Select the print quality from the drop-down list. A higher DPI  
   (Dots Per Inch) number equals a better but more slowly printed copy.

5. Enter the number of copies you want in the Copies: data field. If  
   you're printing more than one copy, and you want each set of pages to  
   print out in order, check the Collate Copies box.

6. Click the Setup button to change printer options. Otherwise, click OK  
   to print your configuration.

Creating Tag  
Name ASCII  
Files

The Tag Name file allows the user to create an ASCII text file for the  
current GX-9100 Tool configuration file. This file can be modified offline  
using any text editor, and read back into any configuration file. The  
information contained in the tag file is job information, user name,  
description, and input and output tags for each defined input, output, and  
program module. In situations where multiple similar controller  
applications exist, modifying and reusing a single file reduces the amount  
of repetitive typing. To do this, use the Read User Names and Write User  
Names menu options in the File pull-down menu as described in the  
following section.
Once you have defined a configuration, all tags, and user-defined names, create an ASCII (text) file containing all tags and user names for that configuration:

1. Select Write User Names from the File pull-down menu while in the configuration from which you want to make the tag file. A Tag Name Dialog box (Figure 93) appears.

   ![Figure 93: Tag Name Dialog Box (Write User Names)]

2. Replace the asterisk (*) in the File Name box with the name you wish to give the .tag file.

3. Use standard Windows methods to select the drive and directory where you wish to place the file.
   
   The Network button only appears if you are on a network. If you need to change to a different server, select the Network button. The Network - Drive Connections dialog box appears. If you need additional assistance concerning using this screen, consult with your network administrator.

4. Select OK to save it.

   Note: The new .tag file (Figure 94) can now be edited using any text editor and/or imported into another configuration as defined in the Read User Names section. A partial example of a typical .tag file is shown here. Following the equal signs (=), you can insert user defined names. The names you enter become the User Names for the appropriate tags in the new configuration. Project Descriptions are limited to 50 characters per line. Tag names are limited to 8 characters, and tag descriptions are limited to 24 characters per line.
Figure 94: Partial Example of a Typical .TAG File

Import Tags and User Names into a configuration from the .tag file created from Write User Names.

1. Select Read User Names from the File pull-down menu from within the configuration into which you want to import the tag file. A Tag Name Dialog box (Figure 95) appears.
2. Use standard Windows methods to select the drive and directory containing the file.

   If you need to change servers, select the Network button. The Network - Drive Connections dialog box appears.

3. Select the desired tag file from the list in the left side box. Select OK. The tag and user-defined names are imported into the open configuration.

   Note: The user names change for the matching modules only.
When the configuration is saved, two DDL files are also created. One has the extension .DMO and is a DDL Model File for mapping CS objects. This file is also used for Template Commissioning in HVAC PRO software. The other file has an extension of .DNC and is an NC DDL file with the hardware items AIn, DIn, AOn, and DOn mapped to appropriate Metasys objects.

To select the items to be included in the DDL files:

1. Select DDL File Options from the File menu. The DDL File Options dialog box (Figure 96) appears.

2. Select All Items or Items Listed Below by clicking on the radio buttons. If you select Items Listed Below, the items in the ITEMS box are enabled and can be selected. Select those items that you want to be included in the DDL files by clicking on their check boxes. The items can be further limited by checking the box “Show only items with user name.”

3. Enter the desired 8-character Metasys System Name.

4. Click on Generate DDL On File Save to remove the check mark, which disables the generation of DDL files. By default, the DDL files are generated when you save the controller configuration.

5. Click OK to save your selection.
Modifying Configurations

You can access an existing configuration in two ways:

- Upload an existing configuration from the controller.
- Open a previously saved configuration file.

Note: We recommended that you save the current configuration before uploading, as the current configuration on the screen is replaced by the configuration uploaded from the controller.

To upload a configuration from the controller:

1. Select Upload from the Action menu. The Upload dialog box (Figure 97) appears.
   If upload is selected while PLC, Trend, or DX Display definition windows are open, an error is displayed. Close all PLC windows associated with the current configuration. Close the Trend window or DX LCD Display definition window. Repeat Step 1.

2. Click the radio buttons to select the item to upload and the port to which the DX controller is connected.

   **Figure 97: Upload Dialog Box**

   XT/XTM selection is not supported when DX is password protected - use DX and XT/XTM selection.
Notes: The port selection file may only be used if the GX Tool is running on a PC with M-Tool software where files with the extensions .DXU, .XTU, or .CLU are stored. These files are created when uploading a configuration from a DX controller via an N30 using the Loader UI program. DXU files contain DX and XT/XTM configuration data. XTU files contain calibration data only. Click OK. The Upload From File dialog box (Figure 98) appears. Select a file to upload.

![Figure 98: Upload From File Dialog Box](image)

Select a file. It is not necessary to enter an address or password. Then proceed to Step 5.

3. Enter the address of the controller from which you are uploading in the Address field. If you are uploading an XT/XTM that is directly connected to the N2 Bus (not connected to the XT Bus of a DX controller), enter the address of the XT/XTM module.

4. Enter the password number of the configuration you are uploading in the DX Password field (only for DX Versions 1.4, 2.4, 3.4, or later). The upload fails if the password number is incorrect.

Note: The DX Password field only appears if the password protection feature is enabled in the GX9100.INI file (see Enabling Password Protection for the DX Download/Upload Dialogs [DX Version 1.4, 2.4, or 3.4] under Software Installation at the beginning of this document).
5. Click OK. Upload first checks whether the configuration in the tool matches the configuration in the controller (unless you are uploading a calibration). Upload DX checks only for DX elements and upload XT/XTM checks against XT1/XTM1 and its associated EXPs, if applicable. Upload DX and XT/XTM checks both. If the check fails, the Config1 dialog box (Figure 99) appears.

![Figure 99: Creating New Configuration](image)

6. Select OK to continue uploading the configuration. The configuration displays on the screen when the upload is completed.

If you have created and saved configurations before, you can open the saved files and modify them. To open a previously saved file:

1. Click the Open button in the toolbar, or select Open from the File menu. The File Open dialog box (Figure 100) appears.

![Figure 100: File Open Dialog Box](image)
2. Select the configuration you want to modify from the File Name list. If the configuration you want does not appear in this list, you can search other directories by clicking on the folders in the Directories box. You can access other drives by selecting them from the Drives drop-down list.

3. Click OK to open the correct configuration file.

To change the configuration of analog inputs and digital outputs:

1. Click the AI or DO with the right mouse button to bring up its pop-up menu.

2. Click Delete. The Config1 dialog box (Figure 101) appears.

3. Click Yes. This deletes the current input/output’s configuration and removes its double border but does not remove the AI or DO from the screen.

4. Click the AI or DO with the right mouse button again to bring up its pop-up menu.

5. Click on the new input/output type. The input/output is reconfigured as the new type, and the double border appears.

To modify the data associated with inputs and outputs, follow the same procedure that you used to enter the data. Call up the data window, enter the new values in the data fields, and click OK to save the changes.
Deleting Modules

To delete a module:
1. Right-click on the module to bring up its pop-up menu.
2. Click Delete. The Config1 dialog box (Figure 101) appears.
3. Click Yes to delete the module or No to cancel the operation.

Modifying Modules

To modify the data associated with modules, follow the same procedure that you used to enter the data. Call up the data window, enter the new values in the data fields, and click OK to save the changes. To change the module type, delete the module and configure a new module.

Modifying Associated Data

Modifying PLC Modules

Modifying Associated Logic Variables

To modify the associated logic variables in a PLC module’s ladder diagram:
1. Double-click on the PLC module block to open its ladder diagram.
2. Click in the middle of the instruction block to modify the associated logic variable. The intermediate menu for associated variables appears (Figure 47).
3. Choose a module from the intermediate menu and click OK. The list of that module’s variables appear.
4. Choose a variable from the list and click OK. The program prompts you to confirm the change.
5. Click Yes to confirm the change. The new associated variable appears above the instruction block.
**Deleting a PLC Instruction Block**

Use the Edit > Delete menu to delete LOAD, LOAD NOT, AND, and AND NOT instructions. When a LOAD or LOAD NOT instruction is deleted, all subsequent instructions in the logic block are deleted. Rebuild or complete the logic block by adding the appropriate instructions.

Use the Edit > Page Reformat menu to fill blank lines created when deleting a LOAD or LOAD NOT. For further details, refer to *Defining PLC Modules*.

**Modifying Instruction Blocks**

To modify an instruction block:

1. Double-click on the PLC module block to open its ladder diagram.
2. Double-click the hot point of the instruction block you want to modify. A list of instructions appears.
3. Select a new instruction and click OK. The program prompts you to confirm the change.
4. Click Yes to confirm the change. The new instruction block appears in the diagram. Note that you have to re-assign an associated variable.

Note: Inserting a LOAD or LOAD NOT instruction by changing another instruction, deletes all instructions subsequent to the new LOAD or LOAD NOT. Complete the logic block by adding the appropriate instructions. Refer to *Defining PLC Modules* for details of other editing features.

**Clearing the Ladder Diagram**

To clear the ladder diagram:

1. Double-click on the PLC module block to open its ladder diagram.
2. Select Clear from the Edit menu. The diagram is cleared.

Note: The program does not prompt to confirm the clear command. Make sure you want to clear the diagram before executing this command, or all data in that diagram is lost. If clear is selected by mistake, the original diagram can be recovered by closing the PLC window without saving the changes and then reopening the window.
Modifying Module Numbers

Edit a module’s number with the following procedure:

1. Right-click the module to bring up its pop-up menu.
2. Click on Change Module Number and the Change Module Number dialog box (Figure 102) appears.

![Change Module Number Dialog Box](change_mod.png)

3. Select the new module number in the list of available choices and click OK. The module appears with the new number.

   Note: When modifying the module number of an XT or XTM with an attached EXP, both the XT/XTM and EXP numbers change. Also, the names of the associated inputs and outputs change.

Calibrating Analog Inputs and Outputs

To calibrate analog inputs or outputs:

1. Upload the calibration values following the procedure in *Uploading a Configuration from the Controller* section of this document. Make sure you click on the radio button next to Calibration when you do the upload.
2. Select Edit > Calibration and the Calibration dialog box (Figure 103) appears.

![Calibration Dialog Box](calibration_dialog_box.png)

**Figure 103: Calibration Dialog Box**

3. Change the values in the edit fields to adjust the input or output.

4. Download the calibration values to the controller following the procedure in *Downloading to a DX Controller*. Make sure you select Calibration when you do the download.

**Notes:** To save calibration data, create a file for each DX controller. The calibration data for each controller is different.

Reversing High and Low output values reverses the action of the output.
Downloading and Uploading a DX Controller via an N30 Supervisory Controller

Note: This feature does not apply to Version 3.x LONWORKS controllers.

This section explains how to download and upload a DX controller using the N30 Supervisory Controller. For details on the N30 Supervisory Controller, refer to the N30 Supervisory Controller Technical Manual (FAN 689.1).

Download a configuration to the DX controller via an N30 Supervisory Controller from a PC using the M-Tool Loader User Interface (UI).

Note: The Loader UI is installed as part of System Tools. Refer to M-Tool Overview and Installation Technical Bulletin (LIT-693100) for details.

To download a configuration through an N30:

1. Select Download via N30 in the Action menu. The Download Via N30 dialog box (Figure 104) appears.

   ![Figure 104: Download Via N30 Dialog Box](image)

Figure 104: Download Via N30 Dialog Box
2. Click the corresponding radio button to select the item to download.

   Notes: Versions 6.0 and 6.01 of the GX Tool did not support the download of the XT/XTM module configuration via the N30 using items DX and XT/XTM or XT/XTM. Use a direct connection to the controller to download these modules or upgrade to Version 7 or later.

   Download via N30 does not support the download of the XT/XTM configuration alone in any version.

3. Enter the address of the controller to which the configuration is to be downloaded in the Address data field. The address must be a number between 1 and 255.

   Note: The address is required to create a download file for the N30 download program. Files with DXF extensions contain DX and XT configuration data. XTF files contain XT/XTM configuration data only. CLF files contain calibration data only.

4. Click OK. The Loader UI program appears.

   Note: The File Name is the path name of the open configuration in the GX-9100 Tool with the extension .DXF, .XTF, or .CLF. The file name cannot be changed.

5. Click the down arrow in the Site Name field to select another site. The name of the site currently connected to the workstation is displayed in the Site Name field.

6. Click Connect Site. The Site Manager appears minimized on the Windows taskbar and establishes a connection with the Site shown in the Site Name field of the Loader UI dialog box (Figure 105).
Figure 105: Loader UI Dialog Box for Download

7. Click the down arrow in the Supervisory Controller field to select the N30 controller connected to the DX controller. A list of the DX controllers connected to the selected Supervisory Controller appears in the field below.

8. Select the DX controller from the list.

9. Click Download to initiate the download process. The GX download dialog box (Figure 106) appears.

Figure 106: Download Dialog Box

Note: When Log File is checked (default), the program writes a series of messages to the errorlog.txt file, recording download progress. The errorlog.txt file is in the C: root directory. Click on the Log File box to deselect this option.
10. Click OK to continue or Cancel to abort the download.

Notes: If the DX controller supports the password protection feature for upload/download (Versions 1.4, 2.3, 3.3, or later), and the password protection feature is enabled in the GX9100.INI file (see Enabling Password Protection for the DX Download/Upload Dialogs [DX Version 1.4, 2.4, or 3.4] under Software Installation at the beginning of this guide), the Password dialog box appears.

If the password protection field is not enabled in the GX9100.INI file, but the DX controller is password protected, the Password dialog box (Figure 107) does not appear, and the download fails.

![Password Dialog Box](image)

**Figure 107: Password Dialog Box**

If the DX controller is password protected, enter the corresponding password and click on OK. The password may be found under Global Data in the GX configuration file that was last used to download the controller. (See Defining the Global Data and Password section earlier in this document.) If the password is not correct, the download fails, and the Password dialog box reappears. After three incorrect entries, the download process is cancelled automatically.

If the DX is not password protected, click on OK to continue.

Download progress is indicated by the progress bar in the Loader UI dialog box. A message box displays the operational steps and commands of the Loader User Interface program. A dialog box appears with a Download Complete or a Download Failed message.

11. Click the Close button to close the Loader UI dialog box and terminate the Site Manager and Loader UI programs when the download is complete. If the download is not successful, refer to the errorlog.txt file for possible causes.
Note: We recommend that you save the current DX and XT/XTM configuration before uploading, as the current configuration on the screen is replaced by the configuration uploaded from the controller.

A configuration can be uploaded via an N30 Supervisory Controller from a PC if M-Tool Loader User Interface (UI) is installed.

Note: The Loader UI is installed as part of System Tools. Refer to *M-Tool Overview and Installation Technical Bulletin (LIT-693100)* for details.

To upload a configuration through an N30:

1. Select Upload Via N30 from the Action menu. The Upload Via N30 dialog box (Figure 108) appears.

2. Click the corresponding radio button to select the item to upload.

   Notes: Versions 6.0 and 6.01 of the GX Tool, did not support the upload of the XT/XTM module configuration via the N30 using items DX and XT/XTM. Use a direct connection to the controller to upload these modules or update to GX Tool Version 7 or later.

   Upload via N30 does not support the upload of the XT/XTM configuration alone in any version.

3. Enter the address of the controller from which the configuration is to be uploaded in the Address data field. The address must be a number between 1 and 255.
Note: The address is required so that an upload file can be created for the N30 upload program. Files with .DXU extension contain DX and XT configuration data. .XTU files contain XT and XTM configuration data only. .CLU files contain calibration data only.

4. Click OK. When the Loader User Interface program has been successfully launched, the Loader UI dialog box (Figure 109) appears.

Note: The File Name field contains the path of the open configuration in the GX Tool with the extension .DXU, .XTU, or .CLU. The file name cannot be changed. If a configuration has not been opened in the GX software, the default name is n2up.xxx.

5. Click the down arrow in the Site Name field to select another site. The name of the site currently connected to the workstation is displayed in the Site Name field.

6. Click Connect Site. The Site Manager appears minimized on the Windows taskbar and establishes a connection with the site shown in the Site Name field.
7. Click the down arrow in the Supervisory Controller field to select the N30 controller connected to the DX controller. A list of the DX controllers connected to the selected Supervisory Controller appears in the field. Select the DX controller from the list.

8. Click Upload to initiate the upload process. The GX Upload dialog box (Figure 110) appears.

![GX Upload Dialog Box](image)

**Figure 110: GX Upload Dialog Box**

Note: If a check mark appears in the Log File box (default), the program writes a series of messages to errorlog.txt file, recording upload progress. The errorlog.txt file is in the C: root directory. Click the Log File box to deselect this option.

9. Click OK to continue or Cancel to abort the upload.

Notes: If the DX controller supports the password protection feature for upload/download (Versions 1.4, 2.3, 3.3, or later), and the password protection feature is enabled in the GX9100.INI file (see *Enabling Password Protection for the DX Download/Upload Dialogs [DX Version 1.4, 2.4, or 3.4]* under *Software Installation* at the beginning of this guide), the GX Download password dialog box (Figure 111) appears.

![GX Download Dialog Box](image)

**Figure 111: Password Dialog Box**

If the password protection field is not enabled in the GX9100.INI file, but the DX controller is password protected, the Password dialog box does not appear, and the upload fails.
If the DX controller is password protected, enter the corresponding password and click on OK. The password may be found under Global Data in the GX configuration file that was last used to download the controller. (See Defining the Global Data and Password section earlier in this document.) If the password is not correct, the upload fails and the Password dialog box reappears. After three incorrect entries, the upload process is cancelled automatically.

If the DX is not password protected, click on OK to continue.

Upload progress is indicated by the progress bar in the Loader UI dialog box, and a message box displays the operational steps and commands of the Loader User Interface program. A dialog box appears with a Download Complete or a Download Failed message.

10. Click Close to close the Loader UI programs and terminate the Site Manager and Loader UI programs when the upload is complete.

If the upload is not successful, refer to the errorlog.txt file for possible causes.

11. Click OK if the upload is successful. Upload checks whether the configuration open in the GX software matches the configuration uploaded from the controller (unless you are uploading a calibration). Upload DX checks only for DX elements, and Upload XT/XTM checks against XT/XTM and their associated EXPs; Upload DX and XT/XTM checks both. If the check fails, the MYCONFIG dialog box (Figure 112) appears.

![MYCONFIG](Match.png)

Figure 112: Modules Do Not Match Dialog Box

12. Select OK. The configuration appears on the screen when the upload is completed, and the configuration data can be saved.
Configuring the DX LCD Display

The process for configuring the DX LCD Display is shown in Figure 113.

Start the GX9100 program.

If you wish to use the User Names, Descriptions, and Units already assigned to points in a DX configuration, then load that configuration into the GX-9100 software.

Define a User Config Code if not already defined in the DX configuration file.

Define the Global Data for the display.

Define the Configuration Name for the display configuration.

Define a Point Database for the display.

Define TSn/OSn Module Descriptions.

Define Trend Data.

If the configuration is to be used as the default, then select it as the default.

Download the configuration and/or Home Page to the display.

Figure 113: DX LCD Display Configuration Process
This section describes the user interface elements of the GX-9100 software that support the DX LCD Display.

Note: In this addendum, the terms “click” and “double-click” always refer to the left mouse button unless it is explicitly stated that you use the right mouse button (to bring up pop-up menus, for example).

The menu bar is across the top of the GX-9100 main window. Click on a menu item to display a drop-down menu listing the corresponding menu options. The GX9100 menu bar (Figure 114) contains eight menu items. Only the DX LCD Display menu options are described in this addendum.

Figure 114: GX-9100 Main Menu Bar
**DX LCD Display Menu**

The DX LCD Display menu contains all the options required to define a configuration for the DX LCD Display. Table 20 describes the DX LCD Display menu options.

**Table 20: DX LCD Display Menu Options**

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Firmware Version</td>
<td>Allows you to select firmware Version 2.01 or Version 3.00.00 or higher.</td>
</tr>
<tr>
<td>Global Data</td>
<td>Allows you to edit global data that affects the operation of the display as a whole, such as the time-out period of the LCD backlight.</td>
</tr>
<tr>
<td>Configuration Name</td>
<td>Allows you to edit the Configuration Name.</td>
</tr>
<tr>
<td>Define Default Configuration</td>
<td>Allows you to define a default configuration to be used by the DX LCD Display in the event that none of the configurations stored in the unit matches the DX controller configuration.</td>
</tr>
<tr>
<td>Point Database</td>
<td>Opens a new window that allows you to define the points that are to be shown on the DX LCD Display.</td>
</tr>
<tr>
<td>TSn/OSn Description Text</td>
<td>Opens a new window that allows you to edit the descriptions for Time Schedule modules and Optimal Start/Stop modules.</td>
</tr>
<tr>
<td>Define Trend Data</td>
<td>Opens a new window that allows you to define the points for which Trend Data is to be shown on the DX LCD Display.</td>
</tr>
<tr>
<td>Download Display</td>
<td>Allows you to download the current configuration to the display unit.</td>
</tr>
<tr>
<td>Read User Configuration Codes</td>
<td>Allows you to read the configuration codes, names, Home Page data, and Trend definitions of all of the configurations currently stored in the DX LCD Display unit.</td>
</tr>
<tr>
<td>Upload Display</td>
<td>Allows you to upload a configuration from the display unit to the GX software on the PC.</td>
</tr>
<tr>
<td>Update Firmware</td>
<td>Allows you to update Version 3.00.00 and higher firmware. Only appears if enabled in the GX9100.INI file (See the Software Installation section for details).</td>
</tr>
</tbody>
</table>
The Point Database, TSn/OSn Description Text, and Define Trend Data options on the DX LCD Display menu open data entry windows for the DX LCD Display. These windows appear over the main GX-9100 window (Figure 115).

Only one window is the active window (i.e., the window that accepts user input) at any given time. To switch between windows, click on the window you want to make active or click on the control box in the upper left corner of the active window and choose Next from the menu that appears. The Ctrl + F6 keyboard shortcut activates each window in turn.

Note: The options on the menu bar may change to correspond to the currently active window.
The active DX LCD Display window changes the menu bar options. Table 21 through Table 24 describe the options of each menu.

**File Menu**

The File menu options save and print the data in the data entry window. Table 21 describes the File menu options.

<table>
<thead>
<tr>
<th>Table 21: File Menu Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menu Option</strong></td>
</tr>
<tr>
<td>New</td>
</tr>
<tr>
<td>Open</td>
</tr>
<tr>
<td>Save</td>
</tr>
<tr>
<td>Print</td>
</tr>
<tr>
<td>Print Preview</td>
</tr>
<tr>
<td>Exit</td>
</tr>
</tbody>
</table>

**Edit Menu**

The Edit menu options enter and manipulate data in the data entry window. Table 22 describes the Edit menu options.

<table>
<thead>
<tr>
<th>Table 22: Edit Menu Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menu Option</strong></td>
</tr>
<tr>
<td>Data</td>
</tr>
<tr>
<td>Cut</td>
</tr>
<tr>
<td>Copy</td>
</tr>
<tr>
<td>Paste</td>
</tr>
<tr>
<td>Delete</td>
</tr>
</tbody>
</table>
Window Menu

The Window menu options cascade, tile, and arrange multiple windows and icons on the screen. Table 23 describes the Window menu options.

Table 23: Window Menu Options

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Arranges multiple windows on the screen in an overlapping stair-stepped fashion.</td>
</tr>
<tr>
<td>Tile</td>
<td>Arranges multiple windows on the screen so that all are visible in a non-overlapping fashion.</td>
</tr>
<tr>
<td>Arrange</td>
<td>Arranges aligned icons (minimized windows) at the bottom of the screen.</td>
</tr>
</tbody>
</table>

Help Menu

The Help menu options display copyright and version information for the configuration tool. Table 24 describes the single option on the Help menu.

Table 24: Help Menu Option

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using GX9100 Help Topic</td>
<td>Launches a Help window with an index of GX-related topics.</td>
</tr>
<tr>
<td>Help Using</td>
<td>Launches window containing help topics for Microsoft Windows Help.</td>
</tr>
<tr>
<td>About</td>
<td>Displays copyright and version information for the GX-9100 Tool.</td>
</tr>
</tbody>
</table>

Toolbar

Table 25 describes the new toolbar buttons that configure the DX LCD Display.

Note: Toolbar buttons appearing dimmed cannot be selected.
<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Menu Bar Equivalent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; New</td>
<td></td>
<td>Opens a new configuration file.</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td></td>
<td>Opens an existing configuration project.</td>
</tr>
<tr>
<td>File &gt; Save</td>
<td></td>
<td>Saves the current configuration.</td>
</tr>
<tr>
<td>File &gt; Print</td>
<td></td>
<td>Brings up the series of print dialog boxes, which allows you to print select items and set print parameters.</td>
</tr>
<tr>
<td>Edit &gt; Cut</td>
<td></td>
<td>Removes selected data and copies it to the clipboard.</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td></td>
<td>Copies selected data to the clipboard.</td>
</tr>
<tr>
<td>Edit &gt; Paste</td>
<td></td>
<td>Pastes the data from the clipboard into the currently selected line.</td>
</tr>
</tbody>
</table>
Right-click on a line of a table in a DX LCD Display data entry window, the line is selected (highlighted in reverse video), and a pop-up menu appears. The active window determines the pop-up menu.

A Point Database pop-up menu (Figure 116) differs from a TSn/OSn Description pop-up menu (Figure 117).

**Figure 116: Point Database Pop-up Menu**
Figure 117: Time Schedule Module Pop-up Menu

Click on a menu option to select it, or highlight it with the arrow keys and press Enter. Click outside of the menu, or press Esc to exit the menu without choosing an option.

Note: The pop-up menu options are the same as the options under the Edit menu.
To define the global data for the DX LCD Display:

1. Select Global Data from the DX LCD Display menu. The DX LCD Display - Global Data dialog box (Figure 118) appears.

![DX LCD Display - Global Data Dialog Box](ctgxmen2)

**Figure 118: DX LCD Display Global Data Dialog Box**
2. Complete the fields in the dialog box. Refer to Table 26.

Table 26: Global Data Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Passwords</td>
<td>Enter a Level 1 password (allows the user to perform all functions) and a Level 2 password (only allows the user to perform adjust commands). Both passwords are 4-digit numbers from 0000 to 9999.</td>
</tr>
<tr>
<td>Password Time out</td>
<td>Enter the time of user inactivity after which the password must be re-entered. The range is from 1 to 1440 minutes (24 hours). Enter 0 to disable the password time out.</td>
</tr>
<tr>
<td>LCD Backlight Time out</td>
<td>Enter the time of user inactivity after which the display panel’s backlight is automatically switched off. The range is from 1 to 30 minutes.</td>
</tr>
<tr>
<td>PC Port</td>
<td>Select the serial port to which the display panel is connected on the PC running the GX Tool. COM1 is Serial Port 1 and COM2 is Serial Port 2. You can also select File to save the configuration data to a file instead of downloading it directly to the display panel (see File Destination for Downloading later in this section).</td>
</tr>
<tr>
<td>Clock Format</td>
<td>Select whether the display panel is to show the time in 12 or 24 hour format.</td>
</tr>
<tr>
<td>Device Poll</td>
<td>Enter addresses and/or ranges to be polled, separated by commas. Choose whether to enable N2 Bus operation.</td>
</tr>
<tr>
<td>Home Page</td>
<td>Choose whether all custom home pages can be accessed from an active configuration.</td>
</tr>
</tbody>
</table>

3. Click OK to save the values and close the dialog box.

File Destination for Downloading (for future use)

Selecting File as the PC Port in the DX LCD Display - Global Data dialog box (Figure 118) activates the Choose Dir. button. (The File writes the display panel configuration data to a file when you choose Download Display from the DX LCD Display menu.) The file name uses the numerical Configuration Code and the file extension .dse.

For example, Configuration Code 99 writes a file named 99.dse. Define the Configuration Code in the User Config Code field of the DX LCD Display - Global Data dialog box for the main controller configuration (found under the Edit menu of the main window). Three additional files provide Home Page data and system information for the emulator: h99.dse, common.dse, and fonts.dse.
To specify the download storage directory (folder) on your PC:

1. Click File for the PC Port in the DX LCD Display - Global Data dialog box (Figure 118).

2. Click on the Choose Dir. The Choose Directory dialog box (Figure 119) appears.

```
Folder:
\gx9100

OK
Cancel
Network...
```

**Figure 119: Choose Directory Dialog Box**

3. Select the location to store downloaded files. Click OK to save the destination and close the dialog box.
To define the DX LCD Display configuration name:

1. Select Configuration Name from the DX LCD Display menu. The DX LCD Display – Change/Edit Configuration Name dialog box (Figure 120) appears.

![Figure 120: Configuration Name Dialog Box](gxt91t_14)

2. Enter the configuration name, using up to 16 characters.

   Note: If you have defined a User Configuration Code in the controller’s Global Data dialog box (found under the Edit menu of the main window), this code is shown in the User Configuration Code field. A User Configuration Code is **required** for downloading. If you have defined a Job Name in the Job Information dialog box (also found under the Edit menu), the first 16 characters of this name are shown in the Configuration Name field. In this case, you may accept or edit the name. The Job Name defined in the Job Information dialog box is unaffected by changes to the Configuration Name.

3. Click OK to save the name and configuration code and close the dialog box.
The DX LCD Display can store up to eight separate display configurations. Each configuration is identified by a configuration name and configuration code. For the procedure that allows you to read the configuration names and codes stored in the display unit, refer to *Displaying the Configuration Codes* later in this section.

When you attach the DX LCD Display to a DX controller, the display attempts to match one of its stored configuration codes with the User Configuration Code defined in the DX controller’s configuration. If it finds a match, then the DX LCD Display uses the corresponding display configuration.

For those cases where the display unit does not find a match, you can use this menu option to tell the unit to use a default configuration and you select which of the eight stored configurations should be the default. If the default configuration feature is not enabled, the display shows a *Configuration not found* message. To enable and select a default configuration:

1. Select Define Default Configuration from the DX LCD Display menu. The DX LCD Display-Define Default Configuration dialog box (Figure 121) appears.

   ![Figure 121: Define Default Configuration Dialog Box](gd10_15)

2. Click Enable Default Configuration box if you want the display unit to use a default configuration when it cannot find a match for the configuration code of the DX controller to which it is connected. Note that if the box is not checked, the position numbers appear dimmed and cannot be selected.

3. Click one of the position numbers (from 1 to 8) to select the configuration stored in that position as the default configuration.

4. Click OK to save your changes or Cancel to close the dialog box without saving your changes.
Note: The default configuration data is stored in the DX LCD Display. Download the display configuration to the display after making changes to the Define Default Configuration dialog box.

The following is intended for use with an emulator program that is not yet developed.

If you selected File as the PC Port in the DX LCD Display Global Data dialog box (Figure 118), then the Define Default Configuration procedure changes. To enable and select a default configuration when the download destination is a file:

1. Select Define Default Configuration from the DX LCD Display menu. The Default Configuration Number dialog box (Figure 122) appears.

2. Click on the Enable Default Configuration box if you want the emulator program to use a default configuration when it cannot find a match for the configuration code in the DX controller to which it is attached. Note that if the box is not checked, the Default Configuration Number field appears dimmed and cannot be edited.

3. Type the configuration code of the configuration you want to use as the default configuration in the Default Configuration Number field.

4. Click OK to save changes or Cancel to close the dialog box without saving changes.

**Figure 122: Default Configuration Number Dialog Box for a File Destination**
Defining the Point Database

The Point Database defines which points of the DX controller are to be shown and monitored by the DX LCD Display. The Point Database is defined in a separate window of the GX-9100 program. To open the Point Database window:

Select Point Database from the DX LCD Display menu. A new window named DX LCD - Display Point Database (Figure 123) appears.

![Figure 123: DX LCD Display Point Database Window](image)

The Point Database window contains 8 separate tables with 12 rows per table, each table representing one of the 8 Point Data screens of the display. The procedures for adding new points to a table, editing point definitions, deleting points, copying points, moving points, and saving the Point Database are described under separate subheadings in the remainder of this section.
To define a new point to be displayed on the DX LCD Display:

1. Select the desired position of the point on one of the eight Point Data screens by clicking on the corresponding row in the table representing the screen. The selected row is highlighted in reverse video.

2. Click on the selected row with the right mouse button, and select Data from the pop-up menu that appears, or select Data from the Edit menu. The Data dialog box (Figure 124) appears.

3. Enter the Tag Name of the new point, or type an asterisk (*) to select the item from a list. (An asterisk is the default entry when the dialog box opens.) Click OK to continue to the next dialog box. The next dialog box that appears depends on what you entered for the Tag Name.

4. If you entered a specific Tag Name, such as AI1, the next dialog box is the point specific Data dialog box for the selected point. Skip to Step 7 in this procedure, which describes the point specific Data dialog boxes.

   If you entered an asterisk (*), then a series of dialog boxes appear that allow you to select from point type categories and subcategories until you have found the individual point that you want to add. Continue with the next step (Step 4) in this procedure.

Notes: The GX Tool uses the terms Tag Name and Item Name (or item) interchangeably. Both terms refer to the controller item abbreviations (e.g., AI1 for Analog Input 1) as shown in the item lists found in this and other documents.

   If you entered an asterisk (*) in the Tag Name field of the Data dialog box (Figure 124), a Select dialog box (Figure 125) appears and shows point type categories.
Figure 125: Select Point Category Dialog Box

The category Network Input/Output is only shown if you have selected DX Version 3.0 or later as the controller type in the Controller menu on the main menu bar.

5. Select a category by double-clicking on it or by clicking on it to highlight it and then clicking OK. Another dialog box appears listing subcategories of the category you chose in the previous dialog box. For example, if you chose DX Input/Output in the DX LCD Display - Points Database (Figure 123), the Select dialog box (Figure 126) appears.

Figure 126: Select Subcategory Dialog Box

6. Select a subcategory by double-clicking on it or by clicking on it to highlight it and then clicking OK. Another dialog box appears listing either additional subcategories or individual points. For example, if you chose Analog Input from the Select dialog box (Figure 126), a Select dialog box listing individual points (Figure 127) appears.
Figure 127: Select Point Dialog Box

Note: There may be several dialog boxes listing subcategories before you reach the dialog box listing individual points. Repeat Step 6 until you find the point you want to add to the table.

7. Select the individual point you want to add to the table by double-clicking on it or by clicking on it to highlight it and then clicking OK. Another dialog box appears, allowing you to define point specific data and parameters for the point. The fields in the dialog box depend on the type of point. For example, if you chose AI1, a Data dialog box (Figure 128) appears.

Figure 128: Analog Input Data Dialog Box

Complete the fields, and click OK to save the data. The fields are described later in this section.

All of the point-specific data dialog boxes have three fields in common as shown in Table 27.
Table 27: Fields in All Point Data Dialog Boxes

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag</td>
<td>Shows the tag (Item) name of the point you selected.</td>
</tr>
</tbody>
</table>
| Description | Enter a freely definable plain text description for the point, using up to 16 characters. The default text in the Description field is taken from the main configuration database, using the following criteria:  
1. If a description is defined for the point in the main database (i.e., by selecting Data from the Edit menu in the main GX-9100 window), then the first 16 characters of this description are shown as the default.  
2. If no description is defined for the point, but a user name is defined, then the user name is shown as the default.  
3. If neither a description nor user name is defined for the point, then the Tag Name is shown as the default.  
You can accept or edit the default description as you wish. This has no effect on the text defined in the main database from which the default was taken. |
| Display Units| Enter the engineering units (up to six characters) that are to be displayed for the point on the DX LCD Display. Note that there are two fields for digital (i.e., binary or 2-state) points: one for the State 0 units and one for the State 1 units.  
For some points there may be a default value in the Display Units field if you have already defined the point’s Measurement Units in the main database (i.e., by selecting Data from the Edit menu in the main GX-9100 window). In this case, you may accept or edit the units as you wish. This has no effect on the Measurement Units defined in the main database. |
| Alarm       | Check this box to define that the alarm limits of the point be monitored by the DX LCD Display and that an alarm is generated on the unit when the point value goes outside the limits. This option is only available for physical input points that have alarm limits. |

For the purposes of the DX LCD Display, all of the points you can add to the Point Database belong to one of four basic types:

- analog input type
- analog output type
- digital input type
- digital output type

The remaining fields in the point-specific data dialog boxes depend on the type and are described under separate subheadings in the remainder of this section.
**Analog Input Type**

For an analog input type, a point-specific Data dialog box (Figure 129) appears. Table 28 describes Analog input fields.

![Analog Input Data Dialog Box](gx91t_23)

**Figure 129: Analog Input Data Dialog Box**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm</td>
<td>Click on this box to define that the alarm limits of the point be monitored by the DX LCD Display and an alarm generated on the unit when the point’s value goes outside of the limits. This option is only available for physical input points that have alarm limits.</td>
</tr>
<tr>
<td>Command</td>
<td>Click on this box to define that the point can be commanded from the DX LCD Display. If this box is not checked, the next two fields appear dimmed and cannot be selected.</td>
</tr>
<tr>
<td>Minimum Commandable Value</td>
<td>Enter the minimum value to which the user can command the point from the DX LCD Display. The allowable range is shown in parentheses.</td>
</tr>
<tr>
<td>Maximum Commandable Value</td>
<td>Enter the maximum value to which the user can command the point from the DX LCD Display. The allowable range is shown in parentheses.</td>
</tr>
</tbody>
</table>

**Note:** A Network Analog Input should only be configured for Command for testing and commissioning purposes. During normal operation, the input is set by a network output of another controller on the network.
**Analog Output Type**

For an analog output type, a point-specific Data dialog box (Figure 130) appears. Table 29 describes Analog output fields.

![Figure 130: Analog Output Data Dialog Box](gx91t_24)

**Table 29: Fields for an Analog Output Type**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>Click on this box to define that the point can be commanded from the DX LCD Display. If this box is not checked, the next two fields appear dimmed and cannot be selected. For some points, the box itself may be dimmed, indicating that it is not possible to command the point.</td>
</tr>
<tr>
<td>Minimum Commandable Value</td>
<td>Enter the minimum value to which the user can command the point from the DX LCD Display. The allowable range is shown in parentheses, and the default value in the field is the lowest value of this range.</td>
</tr>
<tr>
<td>Maximum Commandable Value</td>
<td>Enter the maximum value to which the user can command the point from the DX LCD Display. The allowable range is shown in parentheses, and the default value in the field is the highest value of this range.</td>
</tr>
</tbody>
</table>

**Note:** For some points that cannot be commanded (such as the Network Analog Outputs), the three fields shown above do not appear in the dialog box.
**Digital Input Type**

For a digital input type, a point-specific Data dialog box (Figure 131) appears. Table 30 describes digital input fields.

![Digital Input Data Dialog Box](gx91t_25)

**Figure 131: Digital Input Data Dialog Box**

**Table 30: Fields for a Digital Input Type**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm</td>
<td>Click on the appropriate option (None, State 0, or State 1) to define which state of the point generates an alarm on the DX LCD Display.</td>
</tr>
</tbody>
</table>

For Network Digital Inputs (DX Version 3.n), the field shown below also appears at the bottom of the dialog box.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>Check this box (by clicking on it) to define that the point can be commanded from the DX LCD Display.</td>
</tr>
</tbody>
</table>

**Note:** A Network Digital Input should only be configured for Command for testing and commissioning purposes. During normal operation, the input is set by a network output of another controller on the network.
**Digital Output Type**

For a digital output type, a point-specific Data dialog box (Figure 132) appears. Table 31 describes digital output fields.

![Digital Output Data Dialog Box](image)

**Figure 132: Digital Output Data Dialog Box**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>Click on this box to define that the point can be commanded from the DX LCD Display. For some points, the box may be dimmed indicating that it is not possible to command the point.</td>
</tr>
</tbody>
</table>

**Table 31: Fields for a Digital Output Type**

Notes: For some points that cannot be commanded (such as the Network Digital Outputs), the field shown above does not appear in the dialog box.

Notes: Only those points that have been defined as On/Off, Start/Stop, or Pulse should be added as a digital output type (i.e., included in the database via the DO3-DO8 items). For D.A.T. and P.A.T. outputs, include the value of the analog source in the database instead of the DO3-DO8 items (OUT3-OUT8).

For a full list of the points that can be defined for the display and whether they can be commanded, refer to *Appendix D: DX LCD Display Data Points*.
### Changing a Point Definition

To change the definition of a point that has already been defined:

1. Highlight the point you want to change by clicking on it.
2. Click on the selected row with the right mouse button and select Data from the pop-up menu that appears, or select Data from the Edit menu. The Data dialog box (Figure 133) appears.

![Figure 133: Data Dialog Box](image)

Note: The originally defined Tag Name appears as the default in the Tag Name field.

3. If you want to display a different point at the selected position, enter a new Tag Name, or type an asterisk (*) to select the new item from a list. If you do not want to change the point, simply click OK without editing the Tag Name field.

4. Continue with the procedure described earlier under *Adding a New Point to be Displayed* to change the data and parameters of the point. The fields of the point-specific data dialog box contain the values already defined for the point.

### Deleting a Point

To remove a point from the DX LCD Display database:

1. Highlight the point you want to delete by clicking on it. You can select more than one point by dragging the mouse pointer over the points while keeping the left mouse button depressed. You can also select more than one point by holding the Shift key down (to select a block of consecutive points) or the Ctrl key down (to select a group of non-consecutive points) when you click on the points.

2. Click on the selected point (or points) with the right mouse button, and select Delete from the pop-up menu that appears, or select Delete from the Edit menu.

3. Click on Yes in the message box that appears to confirm that you want to delete the point (or points). Click on No to cancel the operation.
Copying a Point

To make a copy of a point in the DX LCD Display database:

1. Highlight the point you want to copy by clicking on it. You can select more than one point by dragging the mouse pointer over the points while keeping the left mouse button depressed. You can also select more than one point by holding the Shift key down (to select a block of consecutive points) or the Ctrl key down (to select a group of non-consecutive points) when you click on the points.

2. Click on the selected point (or points) with the right mouse button, and select Copy from the pop-up menu that appears, or select Copy from the Edit menu, or click on the Copy button on the toolbar. A copy of the selected point data is placed on the Windows clipboard.

3. Select the row where you want the copy to be placed by clicking on it to highlight it. If you are copying more than one point, then this row marks the starting position for the points. If there is not enough room from the starting position to insert all of the points, then the remaining points are inserted on the next screen starting at the first row.

4. Right-click on the highlighted row, and select Paste from the pop-up menu that appears, or select Paste from the Edit menu, or click on the Paste button on the toolbar. A duplicate of the original point data is pasted into the table starting at the selected position.

If the paste operation would overwrite one or more points that have already been defined in the table, then a warning message appears asking you to confirm that you want to continue with the operation. If you continue, the existing point data is overwritten and lost.

If you are pasting more than one point and the number of rows required would go off the end of Screen 8 (the last screen), then another warning message appears asking you to confirm that you want to continue. If you continue, the rows up to the end of Screen 8 are filled and the rest of the point data is not pasted (however, all of the point data is still on the clipboard).

5. Edit the pasted point data, as required, using the procedure described earlier under Changing a Point Definition. In particular, you may want to change the duplicated Tag Names (items) from those defined in the original data, as described in Step 3 of that procedure.
Moving a Point

To move a point in the DX LCD Display database:

1. Highlight the point you want to move by clicking on it. You can select more than one point by dragging the mouse pointer over the points while keeping the left mouse button depressed. You can also select more than one point by holding the Shift key down (to select a block of consecutive points) or Ctrl key down (to select a group of non-consecutive points) when you click on the points.

2. Click on the selected point (or points) with the right mouse button and select Cut from the pop-up menu that appears, or select Cut from the Edit menu, or click on the Cut button on the toolbar. The selected point data is removed from the table and placed on the Windows clipboard.

3. Continue with the paste operation, which begins with Step 3 of the procedure described earlier under Copying a Point (the only difference being that the original data is not duplicated in the table but is removed from its original position).

Saving the Point Database

To save the DX LCD Display Point Database and close the Point Database window:

1. Save the Point Database by clicking on the Save button on the toolbar or by selecting Save from the File menu.

   Note: Saving the Point Database only saves it within the current controller configuration in memory but does not write the configuration to the computer’s disk. To do that, first make the main configuration window the active window (by clicking on it), and then click on the Save button on the toolbar, or select Save or Save As from the File menu on the main menu bar. This saves all of the DX LCD Display configuration data as well as the main DX controller configuration. The display configuration data is saved in a separate file with the same name as the DX controller configuration file but with a .dsp extension.

2. Close the Point Database window by double-clicking on the control box in the upper left corner of the window (or at the left of the menu bar if the window is maximized) or by clicking on the close box in the upper right corner of the window (or at the right of the menu bar if the window is maximized). The Point Database window closes, and the main configuration window becomes the active window.

   Note: You cannot exit the GX-9100 program if the Point Database window is open.
A freely definable descriptive text string (up to 16 characters) can be associated with each Time Schedule module and each Optimal Start/Stop module for display on the DX LCD Display. These descriptions are defined in a separate window of the GX-9100 program. To open the TSn/OSn Description Text window, select TSn/OSn Description Text from the DX LCD Display menu. A window named DX LCD Display TSn/OSn Description Text (Figure 134) appears.

![Figure 134: TSn/OSn Description Text Window](image)

The TSn/OSn Description Text window contains one table for the Time Schedule modules and another for the Optimal Start/Stop modules. Default descriptions appear in the Description field for each module, and they are taken from the main configuration database using the following criteria:

- If a description is defined for the module in the main database, then the first 16 characters of this description are shown as the default.
- If no description is defined for the module, but a user name is defined, then the user name is shown as the default.
- If neither a description nor user name is defined for the module, then the Tag Name is shown as the default.
You can accept or edit the default description as you wish. This has no effect on the text defined in the main database from which the default was taken.

The procedures for editing and saving the module descriptions are described under separate subheadings in the remainder of this section.

To edit a module description:

1. Select the module you want to edit by clicking on the appropriate row in one of the tables. The selected row is highlighted in reverse video.

2. Click on the selected row with the right mouse button, and select Data from the pop-up menu that appears, or select Data from the Edit menu. A Time Schedule Module Description TS1 dialog box (Figure 135) appears.

![Time Schedule Module Description TS1 dialog box](gx91t_29)

**Figure 135: Time Schedule Description Dialog Box**

The name of the selected module appears in the title bar of the dialog box, and the default description is highlighted for editing.

3. Type the module description, using up to 16 characters, in the Description field, or you may accept the default description. Click OK to save the description or Cancel to close the dialog box without saving your changes.

To delete a module description:

1. Highlight the module whose description you want to delete by clicking on it. You can select more than one module by dragging the mouse pointer over the modules while keeping the left mouse button depressed. You can also select more than one module by holding the Shift key down (to select a block of consecutive modules) or the Ctrl key down (to select a group of non-consecutive modules) when you click on the modules.

2. Click on the selected module (or modules) with the right mouse button, and select Delete from the pop-up menu that appears, or select Delete from the Edit menu.

3. Click Yes in the message box that appears to confirm that you want to delete the description (or descriptions). Click No to cancel the operation.
To save the TSn/OSn module descriptions and close the TSn/OSn Description Text window:

1. Save your changes by clicking on the Save button on the toolbar or by selecting Save from the File menu.
   
   Note: Saving the descriptions only saves them within the current controller configuration in memory but **does not** write the configuration to the computer’s disk. To do that, first make the main configuration window the active window (by clicking on it), and then click on the Save button on the toolbar, or select Save or Save As from the File menu on the main menu bar. This saves all of the DX LCD Display configuration data as well as the main DX controller configuration. The display configuration data is saved in a separate file with the same name as the DX controller configuration file but with a `.dsp` extension.

2. Close the TSn/OSn Description Text window by double-clicking on the control box in the upper left corner of the window (or at the left of the menu bar if the window is maximized), or by clicking on the close box in the upper right corner of the window (or at the right of the menu bar if the window is maximized). The TSn/OSn Description Text window closes, and the main configuration window becomes the active window.

   Note: You cannot exit the GX-9100 program if the TSn/OSn Definition window is open.

The DX controller, Versions 2.3 and 3.3 or higher, can collect and store trend data for up to 12 analog and logic variables. An analog variable corresponds to an analog item in the DX controller, such as an analog output. A logic variable in the DX controller is a byte value representing eight digital bits, such as the eight digital inputs DI1 to DI8. Trend data is collected for all eight bits of the logic variable when any bit changes.

Notes: Three prerequisite steps are required before you can select the Define Trend Data option on the DX LCD Display menu (the option is otherwise dimmed and cannot be selected):

1. The DX controller chosen in the controller configuration (Controller option on the main menu bar) must be a version that supports Trend Data. (You can check this by seeing whether the Trend option appears on the Add PM menu.)

2. You must have added a Trend Log Module to the controller configuration (Trend option on the Add PM menu).
3. You must have defined points to be trended in the Trend Log Module of the controller configuration (double-click on the Trend Log Module). These points (and only these points) are automatically inserted into the same positions of the DX LCD Display Trend Data window.

To open the DX LCD Display Trend Data window, select Define Trend Data from the DX LCD Display menu. The DX LCD Display Trend Data window (Figure 136) appears.

![DX LCD Display Trend Data Window](159 cdr.png)

**Figure 136: DX LCD Display Trend Data Window**

The Trend Data window contains a table showing the points from the Trend Log Module in the controller configuration. The item (tag) names shown are the Items for which the DX is configured to store trend data. Digital items (i.e., a logic variable byte) are shown as a group reference (e.g., DII..8).

For analog items, the description and units are taken from the DX LCD Display Point Database, if the point is defined in the database. If it is not, the Tag Name is used for the description, and there are no units. If you add the point to the Point Database later and then reopen the Trend Data window, the point’s description and units are updated to correspond to the Point Database.
For groups of digital items, the default description is the group reference (e.g., DI1..8), and units do not apply. You can edit the description of the group in the Trend Data window. The procedures for editing and saving the descriptions are described under separate subheadings in the remainder of this section.

To edit a group description:

1. Select the point you want to edit by clicking on the appropriate row in the table. The selected row is highlighted in reverse video.

2. Click on the selected row with the right mouse button, and select Data from the pop-up menu that appears, or select Data from the Edit menu. If the point you selected an analog point, the DX LCD Display - Trend dialog box (Figure 137) appears. If it is a group of digital points, the DX LCD Display - Trend Data dialog box (Figure 138) appears.

![DX LCD Display - Trend Data](image)

**Figure 137: Analog Trend Dialog Box**

The Analog Trend dialog box shows the DX Trend number, Tag name of the point, Description, and Units as static text. You cannot change any of these values using the dialog box. However, the Display Range may be changed from -32768 to +32768.
The Digital Trend dialog box shows the DX Trend number, Tag names, Description, and the eight individual digital items of the group. For each item, the description and units (State 0 and State 1 names) are taken from the DX LCD Display Point Database, if the point is defined in the database. If it is not, the bit number is used for the description, and 0 and 1 are used for the units. If you add the point to the Point Database later and then redisplay the Digital Trend dialog box, the point’s description and state names are updated to correspond to the Point Database.

3. Type the group description, using up to 16 characters, in the Description field, or you may accept the default description. Click OK to save the description or Cancel to close the dialog box without saving your changes.

Figure 138: Digital Trend Dialog Box
To save the digital trend group descriptions and close the Trend Data window:

1. Save your changes by clicking on the Save button on the toolbar or by selecting Save from the File menu.

   Note: Saving the descriptions only saves them within the current controller configuration in memory but does not write the configuration to the computer’s disk. To do that, first make the main configuration window the active window (by clicking on it), and then click on the Save button on the toolbar, or select Save or Save As from the File menu on the main menu bar. This saves all of the DX LCD Display configuration data as well as the main DX controller configuration. The display configuration data is saved in a separate file with the same name as the DX controller configuration file but with a .dsp extension.

2. Close the Trend Data window by double-clicking on the control box in the upper left corner of the window (or at the left of the menu bar if the window is maximized), or by clicking on the close box in the upper right corner of the window (or at the right of the menu bar if the window is maximized). The Trend Data window closes, and the main configuration window becomes the active window.

   Note: You cannot exit the GX-9100 program if the Trend Data window is open.

Up to eight separate display configurations can be stored in the DX LCD Display. Storing a configuration is accomplished by downloading the configuration from the GX Tool to the display through the serial port to which it is connected.

You can also download up to eight different Home Pages to the display. The Home Pages are customizable (see Appendix G: Custom Home Page) and can display live point data from the DX controller. Home Page definitions are stored in separate files that have a file name extension of .hpg. When you open a configuration file in the GX-9100 Tool, it automatically looks for a Home Page file with the same name as the configuration file but with the .hpg extension. For example, if you open a configuration file named config1.dxs, the tool automatically opens the Home Page file named config1.hpg.

   Note: The GX-9100 Tool downloads a default Home Page (named default.hpg) to the DX LCD Display, if it cannot find a custom Home Page with the same name as the open configuration file.
To download a configuration and/or Home Page to the DX LCD Display:

1. Open the DX controller configuration file containing the display configuration you want to download if it is not open. To do this, click on the Open button on the toolbar, or select Open from the File menu on the main menu bar. The File Open dialog box (Figure 139) appears.

![Figure 139: File Open Dialog Box](gx91t_33)

2. Select the configuration file to open and click OK, or double-click on the file name.

3. Select Download Display from the DX LCD Display menu. The DX LCD Display Download dialog box (Figure 140) appears.

![Figure 140: DX LCD Display Download Dialog Box](gx91t_34)
Note: When you select the Download Display menu option, an error message appears if you have not yet specified the PC port to which the display unit is connected. Specify the correct port in the DX LCD Display Global Data dialog box (Figure 118) before continuing. Another error message may appear if you have specified the PC Port, but the configuration tool cannot detect a display panel connected to the port. In that case, check that the panel is properly connected to the correct port as described under Connection to the DX LCD Display earlier in this document.

4. Click on the Point Database box if you want to download the configuration data to the display.

5. Click on the Home Page box if you want to download the Home Page data to the display.

6. Click on one of the Position Numbers (from 1 to 8) to select the display unit storage location into which you want to download the configuration and/or Home Page. The default selection, when you open the dialog box, is the next available, free position in the display unit. You can accept the default or choose another position by clicking on it.

7. Click OK to begin the download operation, or click Cancel to close the dialog box without downloading the configuration. If you are downloading a Home Page file, the GX-9100 Tool performs a syntax check of the file’s contents. If the file fails the syntax check, the tool generates a list of errors and warnings and displays The Home Page Definition File Syntax Check message box (Figure 141) showing the results of the syntax check.

![Home Page Definition File Syntax Check](gx91t_35)

Figure 141: Syntax Check Results Message Box
8. Click on View Error Listing to open a window showing the errors and warnings generated by the syntax check if there were syntax errors in the Home Page file; or click OK to ignore the errors and continue the download operation. For a list of Home Page definition errors, see Appendix G: Custom Home Page in this document.

Notes: When the download operation completes, a message box (Figure 142) appears indicating successful download.

![Download Complete Message Box](gx9100_36)

**Figure 142: Download Complete Message Box**

If a configuration and/or Home Page is already stored in the selected position, then a warning message is shown, and you can choose whether to continue or cancel the download operation. If you continue, the existing configuration and/or Home Page is overwritten in the display.

**Downloading to a File (for future use)**

The following is intended for use with an emulator program that is not yet developed.

If you selected File as the PC Port in the DX LCD Display Global Data dialog box (Figure 118), then the Download Display option writes the display panel configuration data to a file instead of downloading it to a display unit.

The file is named using the numerical Configuration Code and a file name extension of .dse. For example, the file would be named 99.dse if the Configuration Code is 99. The Configuration Code is defined in the User Config Code field of the Global Data dialog box for the main controller configuration (found under the Edit menu of the main window).

Three additional files are created to provide Home Page data and system information for the emulator: h99.dse, common.dse, and fonts.dse.
To download a configuration and/or Home Page to a file destination:

1. Open the DX controller configuration file containing the display configuration you want to download if it is not open. To do this, click on the Open button on the toolbar, or select Open from the File menu on the main menu bar. The File Open dialog box (Figure 143) appears.

2. Select the configuration file you want to open and click OK, or double-click on the file name to open the file.

3. Select Download Display from the DX LCD Display menu. The GX9100 message box (Figure 144) appears and informs you that the configuration data will be written to the file and the directory (folder) path.

**Figure 143: File Open Dialog Box**

**Figure 144: Download to File Message Box**
4. Click OK to write the configuration data to the file and path shown in the message box.

Note: If a file of the same name already exists, then another message box appears asking you to confirm that you want to overwrite the file. Click Yes in the message box to continue, or click No to cancel the operation.

The DX LCD Display can store up to eight separate display configurations. Each configuration is identified by a name and code. To read the configuration codes and associated names stored in the display unit:

1. Select Read Configuration Codes from the DX LCD Display menu. The DX LCD Display - User Configuration Codes dialog box (Figure 145) appears.

<table>
<thead>
<tr>
<th>POSITION</th>
<th>CODE</th>
<th>CONFIGURATION NAME</th>
<th>HOME PAGE</th>
<th>TREND</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Chiller Plant</td>
<td>Custom</td>
<td>Defined</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Boiler Plant</td>
<td>Default</td>
<td>Defined</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>65535</td>
<td>System (Default)</td>
<td>Default</td>
<td>Not Defined</td>
</tr>
</tbody>
</table>

**Figure 145: User Configuration Codes Dialog Box**

For each configuration stored in the display unit, the dialog box shows the storage position number, the configuration code, the associated configuration name, whether the configuration uses the default or a custom Home Page, and whether Trend Data has been defined in the configuration. The default configuration, if defined, is indicated by the word Default in parentheses after the configuration name.
When you select the Read Configuration Codes menu option, an appropriate error message appears if you have not yet specified the PC Port in the DX LCD Display Global Data dialog box (Figure 118) or if the tool cannot detect a display panel attached to the port.

2. Click OK after you have read the codes to close the dialog box.

Note: The Read Configuration Codes option on the DX LCD Display menu appears dimmed and cannot be selected if you have specified File as the PC Port in the DX LCD Display Global Data dialog box (Figure 118).

To upload a configuration and/or Home Page from the DX LCD Display unit to the GX Tool on the PC:

1. Create a new DX controller configuration file by selecting New from the File menu or by clicking on the New button . Save the file to the PC hard disk by clicking on the Save button on the toolbar or by selecting Save from the File menu.

2. Select Upload Display from the DX LCD Display menu. The DX LCD Display Upload dialog box (Figure 146) appears.

![DX LCD Display - Upload](clipxmen5)

**Figure 146: DX LCD Display Upload Dialog Box**

Note: When you select the Upload Display menu option, an error message appears if you have not yet specified the PC Port to which the display unit is connected. Specify the correct port in the DX LCD Display Global Data dialog box (Figure 118) before continuing. Another error message may appear if you have specified the PC Port, but the configuration tool cannot detect a display panel connected to the port. In that case, check that the panel is properly connected to the correct port as described under Connection to the DX LCD Display earlier in this document.
3. Place a check mark in the Point Database box by clicking on it, if you want to upload the configuration data to the GX Tool on the PC.

4. Place a check mark in the Home Page box by clicking on it, if you want to upload the Home Page data to the GX Tool on the PC.

5. Click on one of the Position numbers (from 1 to 8) to select the display unit storage location from which you want to upload the configuration and/or Home Page.

6. Click OK to begin the upload operation, or click Cancel to close the dialog box without uploading the configuration.

Notes: If you click on OK, a GX9100 dialog box (Figure 147) appears and prompts you to reconfirm. This is because the new configuration or Home Page to be uploaded will overwrite the current configuration or Home Page in the GX Tool. Click OK to continue with the upload, or click Cancel to close the dialog box without uploading the configuration.

![Figure 147: Reconfirm Upload Box](ctgxmen7)

When the upload operation is completed, a GX9100 message box (Figure 148) appears to inform you the upload was successful.

![Figure 148: Upload Complete Message Box](ctgxmen6)

7. Save the uploaded file by clicking on the Save button on the toolbar.
This section only describes how to view a print preview and print the DX LCD Display configuration data. For other printing options, such as setting header and footer options, refer to the Printing Configurations section in this document.

To view how the DX LCD Display configuration data will look when printed:

1. Select Print Preview from the File menu. If the main configuration window is the active window, the Print Items dialog box (Figure 149) appears. If one of the DX LCD Display data entry windows is the active window, then the Print Items dialog box is skipped and the Print Preview window (Figure 150) described in Step 5 appears.

2. Click on Items in the Selection section.

3. Select the desired Print Format: Draft (without headers and footers) or Final (with headers and footers).

4. Click on DX LCD Display in the Items section. Select any other items you wish to include in the print preview.
5. Click OK in the Print Items dialog box, and the Print Preview window (Figure 150) opens.

![Print Preview Window](gx91t_40)

**Figure 150: Print Preview Window**

Note: If you opened the Print Preview window from one of the DX LCD Display data entry windows, then only the data of that window appears in the print preview.

6. Click Close to close the Print Preview window and return to the window that was previously active.
Printing the Configuration

To print the DX LCD Display configuration data:

1. Click on the Print button on the toolbar, or select Print from the File menu. If the main configuration window is the active window, the Print Items dialog box (Figure 149) appears. If one of the DX LCD Display data entry windows is the active window, then the Print Items dialog box is skipped and the Print dialog box, described in Step 5, appears.

2. Click on Items in the Selection section.

3. Select the desired Print Format: Draft (without headers and footers) or Final (with headers and footers).

4. Click on DX LCD Display in the Items section. Select any other items you wish to include in the printout.

5. Click OK in the Print Items dialog box, and the Print dialog box (Figure 151) appears.

![Print Dialog Box](image)

**Figure 151: Print Dialog Box**

6. Select the desired Print Range by clicking on the appropriate option. Note that if you choose Page, you also have to enter the starting and ending page numbers in the From and To fields.

7. Select the Print Quality from the drop-down list. A higher dpi (dots per inch) produces a better printout but may take longer to print.

8. Enter the number of copies you want in the Copies field. If you are printing more than one copy and you want each set of pages to be printed in the correct order, click on Collate Copies.
9. Click on the Setup button if you need to change any of the printer options.

10. Click OK to print the configuration data.

Note: If you started printing from one of the DX LCD Display data entry windows, then only the data of that window is printed.
Importing DOS GX-9100 Files

Use the Import feature in the File menu to convert existing DX-9100 Controllers that were programmed using a previous (DOS) version of the GX-9100.

Select Import from the File pull-down menu. The Import dialog box (Figure 152) appears.

1. Use standard Windows methods to select the proper drive, directory, and file to import.

If you need to change the server, select the Network button. The Map Network Drive dialog box (Figure 153) appears. If you need additional assistance concerning this screen, consult your network administrator.
2. Select OK to convert the correct old file (.GPS) in the Import dialog box after highlighting it.

Notes: If there is an existing configuration already in the GX-9100 and it has been modified, the GX9100 dialog box (Figure 154) appears. If it has already been saved, the line, The changes are not saved!, does not appear.

![Figure 154: Changes Are Not Saved Dialog Box](image)

3. If you select Cancel, the import procedure is aborted, so you can save the existing job. If you select OK, the import process continues.

4. The file is converted into the updated format and loaded into GX-9100. When complete, the GX9100 message box (Figure 155) appears.

![Figure 155: Import Is Complete Dialog Box](image)

5. Select OK. You can then modify the configuration, if necessary, and save it as a new .DXS file.
Commissioning

See the DX Commissioning Using the Point Template Program User’s Guide, located in the Programming and Commissioning section of the System 9100 Technical Manual (FAN 636.4 or 1628.4), for detailed commissioning procedures. Among the procedures described in the document are:

• overriding, adjusting, and releasing points
• obtaining information for one or many controllers
• monitoring and graphing controller data
• customizing which points are displayed, their names, units, and how they are grouped
• using a Template File to build a DDL CS Model
• an example Template File with explanations
Troubleshooting

When entering real numbers, the GX-9100 Software Configuration Tool accepts any value between -32750 and 32750. Numbers with a modulus greater than 2048 may be rounded up or down by up to 0.1 percent as shown in Table 32.

Table 32: Rounding Factors

<table>
<thead>
<tr>
<th>Range</th>
<th>Rounding (+/-)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2049-4096</td>
<td>2</td>
</tr>
<tr>
<td>4097-8192</td>
<td>4</td>
</tr>
<tr>
<td>8193-16384</td>
<td>8</td>
</tr>
<tr>
<td>16385-32750</td>
<td>16</td>
</tr>
</tbody>
</table>

The rounding is due to the external communication bus protocol and does not compromise the precision of the internal control process.

Table 33: Common Error Messages

<table>
<thead>
<tr>
<th>Problem</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message: “The source and destination points do not match!”</td>
<td>The source and destinations points are not of the same type (digital or analog). Choose a new source and/or destination point for this connection.</td>
</tr>
<tr>
<td>Error message: “The file could not be opened.”</td>
<td>• The software could not find the file. Check whether the diskette is properly inserted in the diskette drive.</td>
</tr>
<tr>
<td></td>
<td>• The software could not open the file; the file could possibly be corrupted. Use the backup file instead.</td>
</tr>
<tr>
<td>Data window values are deleted upon exiting window.</td>
<td>You may have exited the window by clicking Cancel or pressing the &lt;Esc&gt; key before saving changes. Make sure to click OK to save changes before exiting data windows.</td>
</tr>
<tr>
<td>When exiting a data window, a message appears asking you to enter a number within a specific range; for example, Please enter a number between 1 and 360.</td>
<td>When real and integer values are entered into a data window and you click OK, the GX-9100 Tool checks the values before it saves the changes. If one of the values is outside of the allowed range, the program displays an error message defining the range of the point. Click OK. Change the highlighted value to one within the defined range, and click OK to exit the data window and save your changes.</td>
</tr>
<tr>
<td>A download or upload fails.</td>
<td>If the DX controller is password protected, while the Password option is not enabled in the GX Tool, the download or upload will not succeed.</td>
</tr>
</tbody>
</table>
### Appendix A: Source Points

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACON</td>
<td>The current value of an analog constant set by a BAS, the GX Tool, SX Tool, or on the DX front panel.</td>
</tr>
<tr>
<td>AFB</td>
<td>A 1 when the DO P.A.T. associated feedback value is not responding to changes in the DO P.A.T. command value.</td>
</tr>
<tr>
<td>AIn</td>
<td>The current value of the analog input.</td>
</tr>
<tr>
<td>AI%n</td>
<td>The current value of the analog input in percent (%) of range.</td>
</tr>
<tr>
<td>AIHn</td>
<td>A 1 if the analog input is above its high limit and not below the high limit - limit differential.</td>
</tr>
<tr>
<td>AILn</td>
<td>A 1 if the analog input is below the low limit and not above the low limit + limit differential.</td>
</tr>
<tr>
<td>AOFn</td>
<td>A 1 when an analog output is being externally forced.</td>
</tr>
<tr>
<td>AOHn</td>
<td>A 1 when the analog output is equal to or above its high range.</td>
</tr>
<tr>
<td>AOLn</td>
<td>A 1 when the analog output is equal to or below its low range.</td>
</tr>
<tr>
<td>BATLOW</td>
<td>A 1 when the DX lithium battery needs to be replaced.</td>
</tr>
<tr>
<td>DCON</td>
<td>The current value of a digital constant set by a BAS, the GX Tool, SX Tool, or on the DX front panel.</td>
</tr>
<tr>
<td>DIn</td>
<td>The current status of the digital input.</td>
</tr>
<tr>
<td>DIAL</td>
<td>When set to 1 by a set statement in the PLC, this causes the N2 Dialer to connect the N2 Bus to a BAS via telephone lines. The DIAL bit will be reset to 0 by the BAS when the telephone line connection is successful.</td>
</tr>
<tr>
<td>DICn</td>
<td>Toggles from 0 to 1 or 1 to 0 when the number of digital input transitions (counts) equals the prescaler.</td>
</tr>
<tr>
<td>DOn</td>
<td>The status of the digital output.</td>
</tr>
<tr>
<td>DOnC</td>
<td>A 1 when the BAS has commanded the digital output to be On.</td>
</tr>
<tr>
<td>DOnE</td>
<td>A 1 when the BAS has taken control of the digital output.</td>
</tr>
<tr>
<td>DOFn</td>
<td>A 1 when the digital output P.A.T. or D.A.T. is being externally forced.</td>
</tr>
<tr>
<td>DOHn</td>
<td>A 1 when the digital output P.A.T. or D.A.T. is at its defined high limit.</td>
</tr>
</tbody>
</table>
DOLn A 1 when the *digital output* P.A.T. or D.A.T. is at its defined *low* limit.

HTRR *Historical Trend Read Request.* A 1 when any *trend* log buffer has reached its Read Request limit.

LRSn The *logic result status* of an OUT, OUTNOT, SET or RST statement in a PLC. (Refer to the PLC code to determine which number to use.)

NAIn The analog numeric value that is received over the LONWORKS N2 Network.

NDIn-m The digital value that is received over the LONWORKS N2 Network.

NAIUn A 1 when the network analog shared value is no longer receiving data from the LONWORKS N2 Network.

NDIUn A 1 when the network digital shared value is no longer receiving data from the LONWORKS N2 Network.

OSnHEAT A 1 when *Optimal Start* module is in the *Heating* mode.

OSnOUT A 1 when the *Optimal Start* module requires equipment to be On. It is the controlling *output* of an *Optimal Start* module to START/STOP heating or cooling equipment.

OSnPRE A 1 while the *Optimal Start* module is in the *Pre-conditioning* mode (will turn Off at occupancy).

OSnSTO A 1 when the *Optimal Start* module is in the *Optimal Stop* mode (will turn Off at vacancy - unoccupancy).

OUHn A 1 when an analog or digital *output* is in *Hold* mode from either the DX front panel or BAS.

OULn A 1 when the INC and DEC connections are both On in an analog output module (including P.A.T. or D.A.T.) and the *output is locked.*

OUTn The value of the analog *output* (including P.A.T. or D.A.T.).

OVRn A 1 when the value of the analog *input* is more than 5% above its normal range (overrange condition).

PMnCMH A 1 when a control module’s *output* is equal to its output *high* limit.

PMnCML A 1 when a control module’s *output* is equal to its output *low* limit.

PMnCMP A 1 when the control module’s Working Setpoint (WSP) is being overridden by a BAS (*Computer* mode).
| PMnDISm | A 1 when the output stage is *disabled* in a sequencer module. |
| PMnEF | A 1 when this control module is being *externally forced*. |
| PMnFSSm | A 1 when the totalized value of a totalization module is equal to the *full scale* limit of the channel. |
| PMnHDA | A 1 when the difference Process Variable (PV) - WSP is larger than the *high deviation alarm* value. |
| PMnHEAT | A 1 when, in a symmetric control module, the PV is below the center of the symmetry band and a 0 when above center; or a 1 when, in a dual control module, Loop 1 is active. |
| PMnHHDA | A 1 when the difference PV - WSP is larger than the *high deviation alarm* value. |
| PMnHLD | A 1 when the program module is in the *Hold* mode, being overridden by the SX Tool or a BAS. |
| PMnHLDm | A 1 when the channel of the program module has been overridden (in *hold*) from an SX service module or a BAS. |
| PMnLDA | A 1 when the difference WSP - PV is larger than the *low deviation alarm* value. |
| PMnLLDA | A 1 when the difference WSP - PV is larger than the *low deviation alarm* value. |
| PMnLSm | A 1 when the comparator module channel is at its comparison true logic state. |
| PMnLSP | The value of the *local setpoint*. (This value is changed when adjusting the WSP from the DX front panel.) |
| PMnLSP1 | The value of the *local setpoint* of Loop 1 of a dual control module. (This value is directly changed when adjusting the WSP1 from the DX front panel.) |
| PMnLSP2 | The value of the *local setpoint* of Loop 2 of a dual control module. (This value is changed when adjusting the WSP2 from the DX front panel.) |
| PMnMCSm | A 1 as long as the *maximum cycles status* timer for an output stage is active. |
| PMnMNWS | The value of the *minimum working setpoint* allowed for a control module. |
| PMnMXWS | The value of the *maximum working setpoint* allowed for a control module. |
| PMnNCM | The calculation result of a *numeric module*. |
| PMnNCMm | The calculation result of a channel of a *numeric module*. |
PMnNMH  A 1 when the calculated output is equal to or greater than the numeric module high limit.

PMnNMHm  A 1 when the psychrometric numeric module output is equal to or greater than the high limit of the channel.

PMnNML  A 1 when the calculated output is less than or equal to the numeric module low limit.

PMnNMLm  A 1 when the psychrometric numeric module output is less than or equal to the low limit of the channel.

PMnOCM  The value of the PID control module output in percent; either a 1 or 0 for an On/Off control module.

PMnOUT  The analog value of the requested output load % (percent) of a sequencer.

PMnOUTD  The output difference between the required load minus the sum of the loads of stages that are On in a Sequencer mode. This can be used for Vernier control.

PMnOUTS  The analog value of the output sum of the loads of stages that are On in a sequencer module.

PMnSOF  A 1 when this control module is in the Shutoff mode, which occurs when enable shutoff = 1 and the BAS has commanded it On.

PMnSTA  A 1 when this control module is in the Startup mode, which occurs when enable startup = 1 and the BAS has commanded it On.

PMnSTOm  A 1 when the staged output of a sequencer module is requested to be On.

PMnTDOm  A 1 when the numeric timer channel output is On.

PMnTIMm  The numeric timer module timer value of each channel. It is 0 when the channel is not triggered or the timer has expired; or it is the number of seconds (or minutes, or hours) left as the timer decrements.

PMnTOTm  The totalized value of a totalization module channel; the number of events, runtime, or integration value.

PMnWSP  The value of a control module working setpoint.

PMnWSP1  The value of the working setpoint of Loop 1 of a dual control module.

PMnWSP2  The value of the working setpoint of Loop 2 of a dual control module.

SLF  A 0 when BAS is active and returns to a 1 sixty seconds after receiving the last command from the BAS.
SOFF  A 1 when the BAS has commanded the Shutoff mode.

SSA   A 1 when the BAS is active and returns to 0 two hours after the last command from the BAS.

STUP  A 1 when the BAS has commanded the Startup mode.

TSnEXS A 1 when a time schedule module has its extension enabled by a BAS or a DX front panel command.

TSnOUT A 1 when the real time is currently between the start and stop times of an event of the time schedule module and the current day is specified for that event.

UNRn  A 1 when the value of the analog input is more than 5% below its normal range (underrange condition).

XTnAIM The current value of the analog input from the XT.

XTnAIHm A 1 if the analog input is above its high limit and not below the high limit - limit differential.

XTnAILm A 1 if the analog input is below the low limit and not above the low limit + limit differential.

XTnAOm The value of the analog output to the XT.

XTnCOM A 1 when the extension module is not communicating (wrong address, bus line broken, or bus line overload).

XTnDIM The current status of the digital input from the XT.

XTnDOn The status of the digital output to the XT.

XTnERR A 1 when the XT database in the DX does not match the XT database in the expansion module, when XTnCOM is a 1, or when XTnHARD is a 1 (Versions 1.4, 2.3, 3.3 or later). (Combination of errors for XT/XTM module, i.e., configuring an XP-9102 and connecting an XP-9103 yields an error).

XTnHARD A 1 when the expansion module is not connected or not responding (hardware fault).

XTnOUHm A 1 when an analog or digital output is in Hold mode from either the DX front panel or BAS.

XTnPWR A 1 when the extension module detects a loss of power or loss of communication. The DX will reset this after a few seconds.
## Appendix B: Destination Points

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALD@</td>
<td>The connection to <em>disable</em> alarm processing on <em>analog inputs</em> AI1-AI8.</td>
</tr>
<tr>
<td>AO@</td>
<td>The numeric connection to control an <em>analog output</em>.</td>
</tr>
<tr>
<td>AOF@</td>
<td>The connection to <em>force</em> an <em>analog output</em> to a specified value.</td>
</tr>
<tr>
<td>DEC@</td>
<td>The connection to decrement an analog type output or sequencer module. While connection is a logic 1, the output will <em>decrease</em> at a rate dependent on the type of module.</td>
</tr>
<tr>
<td>DISn@</td>
<td>A connection in a sequencer to <em>disable</em> the corresponding stage or set number.</td>
</tr>
<tr>
<td>DO@</td>
<td>The connection to control a <em>digital output</em>.</td>
</tr>
<tr>
<td>DOF@</td>
<td>The connection for <em>forcing</em> a <em>digital output</em> to a specified value.</td>
</tr>
<tr>
<td>EF@</td>
<td>The connection to the <em>external forcing</em> point of control modules.</td>
</tr>
<tr>
<td>ENL@</td>
<td>The connection to <em>enable</em> output <em>limits</em> of an analog type output (P.A.T. and D.A.T. included).</td>
</tr>
<tr>
<td>FB@</td>
<td>The connection to the <em>feedback</em> of a P.A.T.. Usually a signal from a potentiometer on the controlled device.</td>
</tr>
<tr>
<td>FST@</td>
<td>The connection to set the sequencer module into <em>fast step</em> down mode.</td>
</tr>
<tr>
<td>In@</td>
<td><em>Analog input</em> connections to a programmable module.</td>
</tr>
<tr>
<td>INC@</td>
<td>The connection to increment an analog type output or sequencer module. While connection is a logic 1, the output will <em>increase</em> at a rate dependent on the type of module.</td>
</tr>
<tr>
<td>MNWS@</td>
<td>The connection to the <em>minimum working setpoint</em> of a control module. The WSP cannot be adjusted below this value.</td>
</tr>
<tr>
<td>MXWS@</td>
<td>The connection to the <em>maximum working setpoint</em> of a control module. The WSP cannot be adjusted above this value.</td>
</tr>
<tr>
<td>NAO@m</td>
<td>The numeric source of a Network Analog Output that is shared over the LONWORKS N2 Network.</td>
</tr>
<tr>
<td>NDO@m</td>
<td>The digital source of a Network Digital Output that is shared over the LONWORKS N2 Network.</td>
</tr>
</tbody>
</table>
OB@ The connection of an output bias value of a PID module.

OB1@ The connection for Loop 1 of a dual PID output bias.

OB2@ The connection for the Loop 2 of a dual PID output bias.

OF@ The connection to the Off mode source point of a control module.

OSnDA@ The connection to disable the adaptive action of an Optimal Start/Stop module.

OSnDI@ The connection to disable the Optimal Start/Stop module.

OSnOB@ The connection to the Off Setpoint Bias, which replaces the entered value when connected in an Optimal Start/Stop module.

OSnOT@ The connection for the Outdoor Air Temperature sensor of an Optimal Start/Stop module.

OSnSP@ The connection for the Optimal Start Zone Temperature setpoint. If connected, it replaces the entered setpoint.

OSnTS@ The connection in an Optimal Start/Stop module for the time schedule that determines when the building is occupied.

OSnZT@ The connection for the Zone Temperature sensor in an Optimal Start/Stop module.

PB@ The connection to proportional band, which replaces the value PB if there is a connection.

PV@ The connection to the process variable of a PID or an On/Off.

RA@ The connection to the reverse action point of a control module.

RHn@ The relative humidity sensor connections for psychrometric calculations.

RS@ The connection to a remote setpoint, which is used in the calculation for the working setpoint.

RSn@ The connection to the reset function of a totalization module channel (to reset to 0 and re-start) or timer module channel (to reset the output).

RS1@ The connection for Loop 1 of a dual PID or On/Off remote setpoint.

RS2@ The connection for Loop 2 of a dual PID or On/Off remote setpoint.

RV@ The connection to reference variable, which is a multiplier in the calculation for the working setpoint.
RV1@ The connection for Loop 1 of a dual PID or On/Off reference variable.

RV2@ The connection for Loop 2 of a dual PID or On/Off reference variable.

SB@ The connection to the stand by source point of a control module.

SPn@ A setpoint connection for a comparator channel if a remote setpoint is desired; otherwise, the entered value for the setpoint will be used.

TMn@ The temperature sensor connections for psychrometric calculations.

TSnOF@ A connection to externally force the output of a time schedule to Off.

TSnON@ A connection to externally force the output of a time schedule to On.

TSnEX@ A connection to the external extension override of a time schedule.
Appendix C: Trend Log Items

Table 34 lists the analog items and logic variables that can be defined in a Trend Log module for Metasys Point History. On the Metasys system, the analog inputs are mapped to AI objects, the analog outputs to AOS objects, and the logic variables to BI objects.

Table 35 lists the analog items and logic variables that can be defined in a Trend Log module for the DX LCD Display.

Note: Since a logic variable set is recorded when any one of its variables changes state, it is recommended that you assign LRS logic variable bytes to the trend log and then connect the source variables (the ones that you wish to trend) to the LRS variables in a PLC module (Figure 156).

![Figure 156: Example of Assigning LRS Logic Variable Bytes](image)

<table>
<thead>
<tr>
<th>DX Version</th>
<th>Analog Items</th>
<th>Logic Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.4, 2.4, and Later</td>
<td>AI1 to AI8</td>
<td>DI1..8</td>
</tr>
<tr>
<td></td>
<td>OUT1 to OUT8</td>
<td>LRS1..8</td>
</tr>
<tr>
<td></td>
<td>ACO1 to ACO8</td>
<td>LRS9..16</td>
</tr>
<tr>
<td></td>
<td>XTnAI1 to XTnAI8*</td>
<td>LRS17..24</td>
</tr>
<tr>
<td></td>
<td>XTnAO1 to XTnAO8*</td>
<td>LRS25..32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XTnDI1..XTnDI8*</td>
</tr>
<tr>
<td>2.4 and Later Only</td>
<td>OUT9 to OUT14</td>
<td>–</td>
</tr>
</tbody>
</table>

* Requires Metasys Release 11.00 or later.
<table>
<thead>
<tr>
<th>DX Version</th>
<th>Analog Items</th>
<th>Logic Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.4, 3.4, and Later</td>
<td>AI1 to AI8</td>
<td>DI1..8</td>
</tr>
<tr>
<td></td>
<td>OUT1 to OUT14</td>
<td>LRS1..8</td>
</tr>
<tr>
<td></td>
<td>ACO1 to ACO8</td>
<td>LRS9..16</td>
</tr>
<tr>
<td></td>
<td>XToAI1 to XToAI8</td>
<td>LRS17..24</td>
</tr>
<tr>
<td></td>
<td>XToAO1 to XToAO8</td>
<td>LRS25..32</td>
</tr>
<tr>
<td></td>
<td>PMnK1 to PMnK34</td>
<td>LRS33..40</td>
</tr>
<tr>
<td></td>
<td>PMnOU1 to PMnOU8</td>
<td>LRS41..48</td>
</tr>
<tr>
<td></td>
<td>PMnAX1, PMnAX2</td>
<td>LRS49..56</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LRS57..64</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DO3..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DCO1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DCO9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DCO17..24</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DCO25..32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XToDI1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XToDO1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AIH1..4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AIH5..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AIL1..4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AIL5..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XToAIH1..4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XToAIH5..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XToAIL1..4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>XToAIL5..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PMnDO1..8</td>
</tr>
<tr>
<td>3.4 and Later Only</td>
<td>NAI1 to NAI16</td>
<td>NDI1-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI1-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI2-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI2-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI3-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI3-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI4-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI4-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI5-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI5-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI6-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI6-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI7-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI7-9..16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI8-1..8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NDI8-9..16</td>
</tr>
</tbody>
</table>
Appendix D: DX LCD Display Data Points

The tables in this appendix list the DX controller items that can be included in the DX LCD Display point database.

### Table 36: DX-9100/DX-912x/DX-9200 Hardware Points

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI1-8</td>
<td>No</td>
<td>Analog Input 1-8</td>
</tr>
<tr>
<td>DI1-8</td>
<td>No</td>
<td>Digital Input 1-8</td>
</tr>
<tr>
<td>OUT1-2</td>
<td>Yes</td>
<td>Analog Output 1-2</td>
</tr>
<tr>
<td>DO3-8</td>
<td>Yes</td>
<td>Digital Output 3-8</td>
</tr>
<tr>
<td>OUT3-8</td>
<td>Yes</td>
<td>Value of Analog Source DO3-8</td>
</tr>
<tr>
<td>OUT9-14</td>
<td>Yes</td>
<td>Analog Outputs 9-14</td>
</tr>
</tbody>
</table>

### Table 37: XT-9100 Hardware Points

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>XTnAI1-8</td>
<td>No</td>
<td>XTn Analog Input 1-8</td>
</tr>
<tr>
<td>XTnDI1-8</td>
<td>No</td>
<td>XTn Digital Input 1-8</td>
</tr>
<tr>
<td>XTnAO1-8</td>
<td>Yes</td>
<td>XTn Analog Output 1-8</td>
</tr>
<tr>
<td>XTnDO1-8</td>
<td>Yes</td>
<td>XTn Digital Output 1-8</td>
</tr>
<tr>
<td>n = 1-8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Table 38: DX-912x/DX-9200 Network Inputs/Outputs

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAI1-16</td>
<td>Yes*</td>
<td>Network Analog Input 1-16</td>
</tr>
<tr>
<td>NDIm-n</td>
<td>Yes*</td>
<td>Network Digital Inputs</td>
</tr>
<tr>
<td>NAO1-16</td>
<td>No</td>
<td>Network Analog Output 1-16</td>
</tr>
<tr>
<td>NDOm-n</td>
<td>No</td>
<td>Network Digital Outputs</td>
</tr>
</tbody>
</table>

n = 1-8 (module)  
m = 1-8 (module)  
* Use the Command option for testing and commissioning purposes only. During normal operation, the input is set by a network output of another controller on the network.
### Table 39: DX-9100/DX-912x/DX-9200 Internal Points

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOFF</td>
<td>Yes</td>
<td>Shut off</td>
</tr>
<tr>
<td>STUP</td>
<td>Yes</td>
<td>Start up</td>
</tr>
<tr>
<td>DIAL</td>
<td>Yes</td>
<td>Dial-up Flag</td>
</tr>
<tr>
<td>CNT1-8</td>
<td>Yes</td>
<td>Counter Value 1-8</td>
</tr>
<tr>
<td>XT(n)CNT1-8</td>
<td>Yes</td>
<td>Counter Value XT(n) Digital Input 1-8</td>
</tr>
<tr>
<td>HIA1-8</td>
<td>Yes</td>
<td>Value of High Limit Analog Input 1-8</td>
</tr>
<tr>
<td>LOA1-8</td>
<td>Yes</td>
<td>Value of Low Limit Analog Input 1-8</td>
</tr>
<tr>
<td>XT(n)HIA1-8</td>
<td>Yes</td>
<td>Value of High Limit XT(n) Analog Input 1-8</td>
</tr>
<tr>
<td>XT(n)LOA1-8</td>
<td>Yes</td>
<td>Value of Low Limit XT(n) Analog Input 1-8</td>
</tr>
<tr>
<td>ADF1-8</td>
<td>Yes</td>
<td>Value of Alarm Differential Analog Input 1-8</td>
</tr>
<tr>
<td>AIH1-8</td>
<td>No</td>
<td>High Alarm Flag Analog Input 1-8</td>
</tr>
<tr>
<td>AIL1-8</td>
<td>No</td>
<td>Low Alarm Flag Analog Input 1-8</td>
</tr>
<tr>
<td>XT(n)AIH1-8</td>
<td>No</td>
<td>High Alarm Flag XT(n) Analog Input 1-8</td>
</tr>
<tr>
<td>XT(n)AIL1-8</td>
<td>No</td>
<td>Low Alarm Flag XT(n) Analog Input 1-8</td>
</tr>
<tr>
<td>DCO1-32</td>
<td>Yes</td>
<td>Digital Constant 1-32</td>
</tr>
<tr>
<td>ACO1-8</td>
<td>Yes</td>
<td>Analog Constant 1-8</td>
</tr>
<tr>
<td>LRS1-64</td>
<td>No</td>
<td>Logic Result Status 1-64</td>
</tr>
</tbody>
</table>

\(n = 1-8\)

### Table 40: Programmable Module Items

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PM(m)K1-34</td>
<td>Yes</td>
<td>Module Constant 1-34</td>
</tr>
<tr>
<td>PM(m)OU1-8</td>
<td>Yes</td>
<td>Module Output 1-8</td>
</tr>
<tr>
<td>PM(m)AX1-2</td>
<td>Yes</td>
<td>Auxiliary Output 1-2</td>
</tr>
<tr>
<td>PM(m)CT1-8</td>
<td>Yes</td>
<td>Hold Control 1-8</td>
</tr>
<tr>
<td>PM(m)DO1-8</td>
<td>Yes</td>
<td>Module Logic Output 1-8</td>
</tr>
<tr>
<td>PM(m)S1-16</td>
<td>No</td>
<td>Module Status 1-16</td>
</tr>
<tr>
<td>PM(m)AC1-8</td>
<td>Yes</td>
<td>Accumulator 1-8</td>
</tr>
</tbody>
</table>

\(m = 1-12\)
Appendix E: Item Abbreviations

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>4-SEGM</td>
<td>4 Channel Segment Module (4 break points each)</td>
</tr>
<tr>
<td>8-CALC</td>
<td>8 Channel Calculator Module</td>
</tr>
<tr>
<td>ACO</td>
<td>Analog Constant</td>
</tr>
<tr>
<td>AI</td>
<td>Analog Input</td>
</tr>
<tr>
<td>AO</td>
<td>Analog Output</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>Average Calculation Module</td>
</tr>
<tr>
<td>BIN-SEQ</td>
<td>Binary Code Sequencer</td>
</tr>
<tr>
<td>CALC</td>
<td>Calculation Module</td>
</tr>
<tr>
<td>COMPRTR</td>
<td>Comparator</td>
</tr>
<tr>
<td>D-ONOFF</td>
<td>Dual On/Off</td>
</tr>
<tr>
<td>D-PID</td>
<td>Proportional, Integral and Derivative Controller (2 loops)</td>
</tr>
<tr>
<td>DCO</td>
<td>Digital Constant</td>
</tr>
<tr>
<td>DI</td>
<td>Digital Input</td>
</tr>
<tr>
<td>DO</td>
<td>Digital Output</td>
</tr>
<tr>
<td>EXD</td>
<td>Exception Days</td>
</tr>
<tr>
<td>EXP</td>
<td>Expansion Module (XP2) for XT or XTM</td>
</tr>
<tr>
<td>LRS</td>
<td>Logic Result Status</td>
</tr>
<tr>
<td>MAXIMUM</td>
<td>Maximum Select Module</td>
</tr>
<tr>
<td>MINIMUM</td>
<td>Minimum Select Module</td>
</tr>
<tr>
<td>NAI</td>
<td>Network Analog Input</td>
</tr>
<tr>
<td>NAO</td>
<td>Network Analog Output</td>
</tr>
<tr>
<td>NDI</td>
<td>Network Digital Input</td>
</tr>
<tr>
<td>NDO</td>
<td>Network Digital Output</td>
</tr>
<tr>
<td>ONOFF</td>
<td>On/Off</td>
</tr>
<tr>
<td>OS</td>
<td>Optimal Start/Stop</td>
</tr>
<tr>
<td>PID</td>
<td>Proportional, Integral and Derivative Controller</td>
</tr>
<tr>
<td>PLC</td>
<td>Programmable Logic Controller</td>
</tr>
<tr>
<td>PM</td>
<td>Programmable Module</td>
</tr>
<tr>
<td>Module</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>PSYCHRO</td>
<td>Psychrometric</td>
</tr>
<tr>
<td>SEGMENT</td>
<td>Segment Module (17 break points)</td>
</tr>
<tr>
<td>SELECT</td>
<td>4 Input Select Module</td>
</tr>
<tr>
<td>SEQ</td>
<td>Sequencer</td>
</tr>
<tr>
<td>STA/STO</td>
<td>Start/Stop</td>
</tr>
<tr>
<td>TIMER</td>
<td>8 Channel Time Module</td>
</tr>
<tr>
<td>TOTAL</td>
<td>Totalization</td>
</tr>
<tr>
<td>TS</td>
<td>Time Schedule Module</td>
</tr>
<tr>
<td>XT</td>
<td>XT-9100 Extension Module (includes XP1)</td>
</tr>
<tr>
<td>XTM</td>
<td>XTM-905 Extension Module (includes XP1)</td>
</tr>
</tbody>
</table>
## Appendix F: Comparison with the DOS Version

### Table 41: Comparison to the DOS Version

<table>
<thead>
<tr>
<th>DOS Version Command</th>
<th>Windows Version Command (Menu Option and Keyboard Shortcut)</th>
<th>Toolbar Button or Mouse Action (where applicable)</th>
</tr>
</thead>
<tbody>
<tr>
<td>INFO</td>
<td>Edit &gt; Job Information</td>
<td></td>
</tr>
<tr>
<td>PRINT</td>
<td>File &gt; Print</td>
<td>![Icon]</td>
</tr>
<tr>
<td>DOWNLD</td>
<td>Action &gt; Download</td>
<td></td>
</tr>
<tr>
<td>UPLOAD</td>
<td>Action &gt; Upload</td>
<td></td>
</tr>
<tr>
<td>SAVE</td>
<td>File &gt; Save</td>
<td>![Icon]</td>
</tr>
<tr>
<td>READ</td>
<td>File &gt; Open</td>
<td>![Icon]</td>
</tr>
<tr>
<td>NEW</td>
<td>File &gt; New</td>
<td>![Icon]</td>
</tr>
<tr>
<td>CALIBR.</td>
<td>Edit &gt; Calibration</td>
<td></td>
</tr>
<tr>
<td>REDRAW</td>
<td>(No equivalent command - screen automatically refreshes.)</td>
<td></td>
</tr>
<tr>
<td>VERSION</td>
<td>Controller &gt; DX Version 1.1, 1.2, 1.3 Controller &gt; DX Version 1.4 Controller &gt; DX Version 2.0, 2.1, 2.2 Controller &gt; DX Version 2.4 Controller &gt; DX Version 3.0, 3.1, 3.2 Controller &gt; DX Version 3.4</td>
<td>![Icon]</td>
</tr>
<tr>
<td>GLOBAL</td>
<td>Edit &gt; Global data</td>
<td></td>
</tr>
<tr>
<td>QUIT</td>
<td>File &gt; Exit</td>
<td></td>
</tr>
<tr>
<td>SOURCE</td>
<td>Edit &gt; Connect or F5 Key</td>
<td>![Icon] Click and drag the bent arrow from the source point to the destination point.</td>
</tr>
<tr>
<td>DATA</td>
<td>Edit &gt; Data</td>
<td></td>
</tr>
<tr>
<td>DELETE</td>
<td>Edit &gt; Delete</td>
<td></td>
</tr>
<tr>
<td>CONN</td>
<td>View &gt; Show Connections</td>
<td></td>
</tr>
</tbody>
</table>
Appendix G: Custom Home Page

The Home Page is intended for use as a graphic display of important parameters that are useful to show in a default screen. The Home Page displays static and dynamic graphics, which can include changing symbols, bar graphs, and characters in any language.

The Home Page is defined in an ASCII file format with references to bitmap files. The GX-9100 Tool reads the Home Page definition file (*.hpg) and downloads the required bitmaps (*.bmp) and other related information to the DX LCD Display panel. The DX LCD Display can store up to eight different Home Pages. When you open a configuration file in the GX-9100 Tool, it automatically looks for a Home Page file with the same name as the configuration file but with the .hpg extension. For example, if you open a configuration file named config1.dxs, the tool automatically opens the Home Page file named config1.hpg.

Note: The GX-9100 Tool downloads a default Home Page (Figure 157), named default.hpg, to the DX LCD Display if it cannot find a custom Home Page with the same name as the open configuration file.

Figure 157: Default Home Page
You have complete control over the contents of the Home Page. Apart from referencing user-created bitmaps, the Home Page can also reference standard bar graph symbols available in the DX LCD Display. You can associate analog and digital items with these images.

The individual contents of the Home Page are described under separate subheadings in the remainder of this section. They include the following:

**Text**
Dynamic text for the display of numeric items can be included in the Home Page. Dynamic text is typically associated with analog items such as AI1, clock time, etc. The text can be displayed in one of three font sizes. The various sizes are:

- **small** - 6 pixels wide by 8 pixels high
- **medium** - 12 pixels wide by 16 pixels high
- **large** - 24 pixels wide by 32 pixels high

When you load a Home Page file, the GX-9100 Tool verifies that no text goes beyond the limits of the LCD display (240 pixels wide by 128 pixels high).

**Static Bitmaps**
These are normally used as the background of the Home Page. Labels, units, and any other static text can be a part of the static bitmap. The bitmap is created using any standard bitmap editor, and the .bmp file is referenced in the Home Page definition file.

**Dynamic Bitmaps**
These are associated with digital items. Different bitmaps are associated with State 0 and State 1. This feature can be used to display changing images that represent the states of the digital item. You create the State 0 and State 1 bitmaps, so you have complete control over their appearance.

**Bar Graph**
A bar graph can be linked to an analog item. You specify the values of the analog source for 0% and 100%. The bar size changes, as the input changes from 0% to 100%.

**Alarm Line**
This type is used to display the most recent alarm and the total number of alarms in the small font size on any line of the Home Page.

**Clock**
This type is used to display the current time in 12-hour (hh:mm a/p) or 24-hour (hh:mm) format in the small, medium, or large font size on the Home Page.
Use any standard ASCII text editor (such as Windows Notepad) to create the Home Page definition file. Give the file the same name as the associated DX configuration file but use a .hpg file name extension. Use any standard paint program (such as Windows Paint) to create monochrome Windows bitmap files (.bmp). The syntax for the Home Page definition file is described under the next subheading.

The syntax rules for defining a Home Page are presented in this section. When you load the Home Page file into the GX-9100 Tool, it performs a syntax check and lists any errors or warnings that it finds in the file. An example of a Home Page definition file and a list of syntax errors follow at the end of this section.

**Tokens**

Tokens are shown in angle brackets (<>) and are used as place holders in the statement rules. Wherever a token appears in a rule, replace it with an appropriate value, taking the ranges or possible choices into account. The tokens are listed in Table 42, and the special characters that can be used in the definition file are listed in Table 43.

<table>
<thead>
<tr>
<th>Token</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;row&gt;</td>
<td>1 to 128</td>
<td>Pixel row of display</td>
</tr>
<tr>
<td>&lt;col&gt;</td>
<td>1 to 240</td>
<td>Pixel column of display</td>
</tr>
<tr>
<td>&lt;bmp top l row/col&gt;</td>
<td>1 to 65535</td>
<td>Top left row/column offset of image in bitmap file</td>
</tr>
<tr>
<td>&lt;bmp bot r row/col&gt;</td>
<td>1 to 65535</td>
<td>Bottom right row/column offset of image in bitmap file</td>
</tr>
<tr>
<td>&lt;height&gt;</td>
<td>1 to 128</td>
<td>Height in pixels</td>
</tr>
<tr>
<td>&lt;width&gt;</td>
<td>1 to 240</td>
<td>Width in pixels</td>
</tr>
<tr>
<td>&lt;font_size&gt;</td>
<td>small, medium, large</td>
<td>6 x 8 pixel font, 12 x 16 pixel font, 24 x 32 pixel font</td>
</tr>
<tr>
<td>&lt;orientation&gt;</td>
<td>horizontal, vertical</td>
<td>Bar graph orientation</td>
</tr>
<tr>
<td>&lt;show status&gt;</td>
<td>status, no_status</td>
<td>Specifies whether to display the analog item status.</td>
</tr>
<tr>
<td>&lt;12_24_format&gt;</td>
<td>12 to 24</td>
<td>12- to 24-hour time format</td>
</tr>
<tr>
<td>&lt;name&gt;</td>
<td>12 to 24</td>
<td>String enclosed in double quotes. Example: &quot;MASP&quot;</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>carriage return</td>
<td>Delimiter for each line</td>
</tr>
<tr>
<td>\</td>
<td>Used for continuation of any line.</td>
</tr>
<tr>
<td>*</td>
<td>Placed at beginning of line for single line comment (multiple line comments are not allowed).</td>
</tr>
</tbody>
</table>
**Statements**

Most statements place elements on the Home Page. For static backgrounds and digital items, where you specify a bitmap file name, you must also specify the offset of the image within the bitmap file. This is very useful if you want to store all of the Home Page images in one bitmap file and then refer to different images in the file by specifying their coordinates.

The following examples show Home Page syntax.

**Begin Home Page Definition:**

BEGIN_HOMEPAGE  <name>

The `<name>` serves only as an identifier for the Home Page definition and is not downloaded to the DT-9100 display.

**End Home Page Definition:**

END_HOMEPAGE

**Static Bitmap:**

```
<row> <col> STATIC \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> <bitmap file>
```

The bitmap must be monochrome.

**Analog Item:**

```
<row><col>ANALOG<font size> \ 
<no of digits after decimal point>\ 
<show status><item tag>
```

**Digital Item:**

```
<row> <col> DIGITAL \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> <bitmap file for off> \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> <bitmap file for on> \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> \ 
<bitmap file for override off> \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> \ 
<bitmap file for override on> <item tag>\ 
```

The OFF (State 0) and ON (State 1) bitmaps must be the same size. Similarly, the override OFF and override ON bitmaps must be the same size. If an override OFF bitmap is specified, then an override ON bitmap is also required. All bitmaps must be monochrome.

For digital input type items, you do not have to specify bitmap files for override OFF and override ON (i.e., you can omit them from the DIGITAL statement).
For digital output type items, you must specify override OFF and override ON bitmap files. They can, however, be the same bitmaps as the normal OFF and ON bitmaps. The override bitmaps are displayed at the same position as the OFF and ON bitmaps (i.e., they replace them on the display).

**Alarm Line:**

```
<row>  ALARM_LINE
```

The ALARM_LINE begins at the first column and has a height of eight pixels. Only one alarm line is allowed on a Home Page. The row for the alarm line must be a multiple of eight.

**Bar Graph:**

```
<row>  <col>  BARGRAPH  <width>  <height>  \ 
    <orientation>  <src val for 0%>  \ 
    <src val for 100%>  <item tag>
```

A rectangle is drawn around the bar graph by leaving a one pixel gap on each side to indicate the bar graph’s boundary.

**Clock:**

```
<row>  <col>  CLOCK  <font_size>  <12_24_format>
```

For 12-hour format, the clock occupies six characters (hh:mm a/p) and for 24-hour format, it occupies five characters (hh:mm) of the size defined by `<font_size>`.

**Home Page Definition File Example**

A Home Page definition file (Figure 159) defines a custom Home Page (Figure 158).
**Figure 158: Home Page Example**

```
** put all rectangles, units, and fixed text in the static bitmap
*
BEGIN_HOMEPAGE "plant1"
  0 0 STATIC 2 2 129 241 "plant1.bmp"
  10 10 ANALOG LARGE 0 NO_STATUS AI1
  10 130 ANALOG LARGE 0 NO_STATUS AI2
  72 170 DIGITAL 140 2 147 13 "plant1.bmp" 150 2 157 13 "plant1.bmp" DI1
  80 170 DIGITAL 140 2 147 13 "plant1.bmp" 150 2 157 13 "plant1.bmp" DI2
  88 170 DIGITAL 140 2 147 13 "plant1.bmp" 150 2 157 13 "plant1.bmp" DI3
  96 170 DIGITAL 140 2 147 13 "plant1.bmp" 150 2 157 13 "plant1.bmp" DI4
  104 170 DIGITAL 140 2 147 13 "plant1.bmp" 150 2 157 13 "plant1.bmp" DI5
END_HOMEPAGE
```

**Figure 159: Home Page Definition File**

![Home Page Example](image-url)
Table 44 lists the DX LCD Display (DT-9100) Home Page definition errors and solutions.

### Table 44: Home Page Definition Errors

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Syntax Check Message</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bitmap File Type</strong></td>
<td>Error Line :6 Bitmap Error, only monochromes are supported</td>
<td>Reopen the bitmap file in Paint. Change Save As type to Monochrome Bitmap and resave.</td>
</tr>
<tr>
<td><strong>Bitmap file not found</strong></td>
<td>Error Line :6 Bitmap file not found</td>
<td>The Home Page file (<em>.hpg) references a bitmap file (</em>.bmp) that is not located in the same directory. Locate bitmap file in the same directory as the Home Page file.</td>
</tr>
<tr>
<td><strong>Bitmap dimension mismatch, Bitmap is smaller than that specified</strong></td>
<td>Error Line :6 Bitmap is smaller than that specified</td>
<td>Increase the bitmap file size to match the Home Page definition. The bitmap file can be larger than what is defined without producing an error. The DT-9100 displays only what appears in the area up to 240 pixels wide by 128 pixels high.</td>
</tr>
<tr>
<td><strong>Multiple alarm lines</strong></td>
<td>Error Line :42 Multiple alarm lines not allowed.</td>
<td>Delete all but one alarm line.</td>
</tr>
<tr>
<td><strong>Overlapping area</strong></td>
<td>Error Line :42 Overlap error, at least two areas overlap, dynamic data items, Digital, Analog</td>
<td>The overlapping items could be analog or digital. To determine overlapping areas, open the static bitmap file, and locate the dynamic item referenced in the error line. Locate other dynamic items near the referenced item. Check the coordinates from the definition of the items in the Home Page file (coordinate refers to location of the upper left corner of the dynamic item and its font size). Relocate the referenced item, so it does not contact another item.</td>
</tr>
<tr>
<td><strong>Statement type not recognized</strong></td>
<td>Error Line :33 Statement type not recognized. DO, DI, Digital</td>
<td>Digital items typically use backslash (\ ) as part of the definition. Verify backslash used for line continuation includes space before special character. Example: 90 160 DIGITAL \ 141 22 151 63 “DX-22.BMP” \ 129 22 139 63 “DX-22.BMP” \ DO3</td>
</tr>
<tr>
<td><strong>Not enough space to show ANALOG item</strong></td>
<td>Warning Line :11 Not enough space to show ANALOG item</td>
<td>Dynamic Analog item is overlapping an area of the static bitmap that contains an image. Relocate the Analog item. To determine the overlapping area, open the static bitmap file, and locate the analog item referenced in the Error line. Locate the static image (i.e., labels units, text, etc.) near the analog item. Check the coordinates from the definition of the analog item in the Home Page file (coordinate refers to location of the upper left corner of the dynamic item and its font size).</td>
</tr>
<tr>
<td><strong>Number of Parameters not correct for type DIGITAL</strong></td>
<td>Error Line :30 Number of Parameters not correct for type DIGITAL</td>
<td>Digital items typically use backslash (\ ) as part of the definition. Verify backslash used for line continuation includes space before special character. Example: 90 160 DIGITAL \ 141 22 151 63 “DX-22.BMP” \ 129 22 139 63 “DX-22.BMP” \ DO3</td>
</tr>
</tbody>
</table>
Appendix H: Customizing the DX LCD Display Main Menu

You can customize the DX LCD Display Main menu, so that certain features do not appear. This may be desirable for Original Equipment Manufacturer (OEM) customers who do not require certain functions normally supported by the DX LCD Display, such as time programs or Optimal Start/Stop.

To customize, change the text in the GX language file (dxmisc.lng), so that the length of a menu description is equal to zero and the corresponding menu is not shown.

Open the GX language file (dxmisc.lng) in an ASCII text editor (such as WordPad or Notepad). Any of the menus in lines 16068 to 16078 of the file may be hidden by removing the menu text between quotation marks.

In the following example, line 16075 for Optimal Start/Stop is altered so that Optimal Start/Stop will not appear in the DX LCD Display Main menu. The line is duplicated, so there are two of the same. An asterisk is placed in front of the first line 16075 to disable it. In the second line 16075, which is enabled, Optimal Start/Stop is deleted, so that nothing appears between the sets of quotation marks ("""). By duplicating the line and editing it as shown in the following example, you can easily add the menu again when required.
Save your changes to the file before you close it.
Appendix I: Updating DX LCD Display Firmware

You can update a DT-9100 with firmware Version 3.00.00 via the DX LCD Display Update Firmware menu, if you have enabled the option in the GX9100.INI file. See the Software Installation section for more details.

⚠️ CAUTION: All configuration data in the DT-9100 is lost after updating the firmware. To avoid data loss, upload and save to disk all configurations and Home Pages from the DT-9100 before updating the firmware.

To update the firmware:

1. Select Update Firmware from the DX LCD Display menu. The DX LCD Display Update Firmware dialog box (Figure 160) appears.

![Figure 160: Firmware Update Dialog Box](dtchoose)

Figure 160: Firmware Update Dialog Box
2. Choose the file name, and click OK to continue. The dxd_dldr DOS window (Figure 161) appears.

![DOS Window](image)

**Figure 161: DOS Window**

3. Press <0> (zero) to abort the download procedure and return to the GX Tool, or press the <return> key to start the download procedure. If you press the <return> key, the DT-9100 is reset and the screen is blank. The download begins (Figure 162).
Parsing Download file, Please wait.
Parsing Download file, Please wait.
Waiting to start boot load to DX Display.
Press the zero <0> key to exit this program.
Press the return <cr> key to start sending the initial download.
Received boot load request from user.
Sending boot load request from user.
Sending boot load to DX Display.
*DS* first load size = 69
DS oRxByte is ff
Completed first boot load to DX Display.
Sending second boot load @ 9600 bps
Press the zero <0> key to exit this program.
*DS* second load size = 530
Waiting for acknowledge...

Second boot load to DX Display Completed.

Sending third boot load @ 9600 bps
Press the zero <0> key to exit this program.
148608 bytes sent out of 262144 bytes total.

Figure 162: Download Starting

Note: When the download is complete, the Finished - dxd_dldr window (Figure 163) appears, and the DT-9100 is reset.
4. Close the download to return to the GX Tool.